Nápověda k programu WebGen.cz

Co je WebGen.cz

WebGen.cz je offline generátor HTML aplikací. Pracuje v režimu:

e- katalog
e-obchod
redakční systém
weblog
expert
fotogalerie

WebGen.cz je vytvořen jako aplikace produktu firmy Software602, a.s. 602SQL ver.8.1.
Jedná se o aplikaci pro uživatele, kteří potřebují vytvořit navzájem propojené stránky se stejným vzhledem, snadnou údržbou a aktualizací. Uživatel nemusí mít téměř žádné znalosti z tvorby HTML souboru. Je určena nejen pro laiky, ale i pro profesionály, kterým usnadní vytváření HTML aplikací.
Produkt pro svou fukci potřebuje na straně klienta internetový prohlížeč řady 4.0 vyšší. Je nezávislý na poskytovateli Internetu a na aktivní podpoře serveru. Po instalaci stačí nastavit základní parametry, naplnit data z vašeho informačního systému pomocí importu, připravit obrázky zboží a spustit generátor. Vzniklý HTML kód lze publikovat na Internet nebo nahrát na jiný datový nosič.

Novinky v programu

602.28 (12.11.2007)
Nové
  • v záložce č. 5 je možné zadávat textové údaje pomocí comba
  • podpora online půjček CETELEM
  • <!-- %IS_PAR_LOG_1()% --> zapíše se parametr pokud je PAR_LOG1 zatržený
  • <!-- %IS_PAR_LOG_2()% --> zapíše se parametr pokud je PAR_LOG2 zatržený
  • <!-- %IS_PAR_LOG_3()% --> zapíše se parametr pokud je PAR_LOG3 zatržený
  • <!-- %TYPE_IMG_III% --> další obrázky s popisem, záložka 11, které se otevírají pomocí Lightbox2, ukázka
  • <!-- %TYPE_IMG_IV()% --> zobrazí parametr, pokud existují další obrázky (záložka 11), které se otevírají pomocí Lightbox2, ukázka
  • <!-- %TYPE_IMG_V()% --> zobrazí parametr, pokud neexistují další obrázky (záložka 11), vygeneruje odkaz na detailní obrázek, který se otevře pomocí Lightbox2, ukázka
  • <!-- %COMBO_PRODUCER% --> vygeneruje kód pro zobrazení obsahu comba s údajem výrobce <option value="XXX">XXX</option>
  • <!-- %COMBO_PARSTR0% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR0 <option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR1% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR1<option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR2% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR2 <option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR3% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR3 <option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR4% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR4 <option value="XXX">XXX</option>, ukázka
  • <!-- %COLUMN_START_ALL% --> <!-- %COLUMN_END% --> začátek/konec sloupku - vždy všechny údaje
  • <!-- %CONTENT_P% --> pouze anotace sloupku
  • <!-- %VIEW_GOODS_START()% --> <!-- %VIEW_GOODS_END% --> začátek/konec údajů o kartě. V parametru je volba třídění
    např.
    (ORDER BY kod DESC) - dle položky sestupně
    (ORDER BY NAZEV) - dle názvu

602.272 (1.1.2007)
Nové
  • platební brány
    • PayPay
    • Moneybookers
  • klíčová slova (režim expert)
    • <!-- %TABLE_2_HREF()% --> záložka 13 (tabulka varianta 2), pravé tl. myši nalistování souboru 1. sloupec odkaz, 2. sloupec text odkazu
    • <!-- %TABLE_2_HREF_W()% --> záložka 13 (tabulka varianta 2), pravé tl. myši nalistování souboru 1. sloupec odkaz, 2. sloupec text odkazu. Odkazy se otevírají do nového okna
    • <!-- %COUNT_RELATED_FILE1% --> počet souvisejících položek 1
    • <!-- %COUNT_RELATED_FILE2% --> počet souvisejících položek 2
    • <!-- %COUNT_RELATED_FILE3% --> počet souvisejících položek 3
    • <!-- %NAME_PAR_STR_0% --> název sloupce NAME_PAR_STR_0
    • <!-- %NAME_PAR_STR_1% --> název sloupce NAME_PAR_STR_1
    • <!-- %NAME_PAR_STR_2% --> název sloupce NAME_PAR_STR_2
    • <!-- %NAME_PAR_STR_3% --> název sloupce NAME_PAR_STR_3
    • <!-- %NAME_PAR_STR_4% --> název sloupce NAME_PAR_STR_4
    • <!-- %NAME_PAR_STR_5% --> název sloupce NAME_PAR_STR_5
    • <!-- %NAME_PAR_NUM_1% --> název sloupce NAME_PAR_NUM_1
    • <!-- %NAME_PAR_NUM_2% --> název sloupce NAME_PAR_NUM_2
    • <!-- %NAME_PAR_NUM_3% --> název sloupce NAME_PAR_NUM_3
    • <!-- %NAME_PAR_INT_1% --> název sloupce NAME_PAR_INT_1
    • <!-- %NAME_PAR_INT_2% --> název sloupce NAME_PAR_INT_2
    • <!-- %NAME_PAR_INT_3% --> název sloupce NAME_PAR_INT_3
    • <!-- %NAME_PAR_DAT_1% --> název sloupce NAME_PAR_DAT_1
    • <!-- %NAME_PAR_DAT_2% --> název sloupce NAME_PAR_DAT_2
    • <!-- %NAME_PAR_DAT_3% --> název sloupce NAME_PAR_DAT_3
    • <!-- %NAME_PAR_LOG_1% --> název sloupce NAME_PAR_LOG_1
    • <!-- %NAME_PAR_LOG_2% --> název sloupce NAME_PAR_LOG_2
    • <!-- %NAME_PAR_LOG_3% --> název sloupce NAME_PAR_LOG_3
    • <!-- %VIEW_GOODS_START_RELATED_FILE()% --> začátek skupiny související položky s možnosti definování třídění v parametru. Např.
      <!-- %VIEW_GOODS_START_RELATED_FILE(ORDER BY kod DESC)% --> dle položky sestupně
      ORDER BY NAZEV dle názvu
      ORDER BY CENABDPH dle ceny bez DPH
    • <!-- %VIEW_GOODS_START_RELATED_FILE2()% --> začátek skupiny související položky 2 s možnosti definování třídění v parametru.
    • <!-- %VIEW_GOODS_START_RELATED_FILE3()% --> začátek skupiny související položky 3 s možnosti definování třídění v parametru.
    • <!-- %VIEW_GOODS_START_01% --> začátek položek 1. sloupec ze 3
    • <!-- %VIEW_GOODS_START_02% --> začátek položek 2. sloupec ze 3
    • <!-- %VIEW_GOODS_START_03% --> začátek položek 3. sloupec ze 3
    • <!-- %ITEM_ON_PAGE% --> počet položek na stránce s přehledem zboží
    • <!-- %STRING_1% --> sloupec STRING_1 článku (i pro režim weblog)
    • <!-- %STRING_2% --> sloupec STRING_2 článku (i pro režim weblog)
    • <!-- %IS_STRING_1()% --> jestliže je vyplněn obsah sloupce STRING_1 článku, zobrazí se obsah parametru (i pro režim weblog)
    • <!-- %IS_STRING_2()% --> jestliže je vyplněn obsah sloupce STRING_2 článku, zobrazí se obsah parametru (i pro režim weblog)

602.271 (16.10.2006)
Nové
  • podpora platební brány PayPal logo-xclick2.gif, 1 kB

602.27 (3.8.2006)
Nové
  • <!-- %TREE_OKNO_UL()% --> seznam odkazů všech skupin zboží (formát <UL> <LI>), zobrazení odkazu v hlavním okně rámu, v parametru je parametr hlavního tagu <UL> , např. <!-- %TREE_OKNO_UL(id="mb1")% -->, výsledek <UL id="mb1"> (režim expert)
  • <!-- %TREE_UL()% --> seznam odkazů všech skupin zboží (formát <UL> <LI>), zobrazení odkazu v aktuálním okně, v parametru je parametr hlavního tagu <UL > , např. <!-- %TREE_UL(id="mb1")% -->, výsledek <UL id="mb1"> (režim expert)
  • <!-- %VIEW_GOODS_START_GROUPS_TIP_0% --> začátek bloku zboží náležící do aktuální nadřízené skupiny označené jako TIP - sudé položky (režim expert)
  • <!-- %VIEW_GOODS_START_GROUPS_TIP_1% --> začátek bloku zboží náležící do aktuální nadřízené skupiny označené jako TIP - liché položky (režim expert)
  • <!-- %ARCHIVE_YEAR()% --> seznam odkazů do archivu dle roku a následně dle měsíce. V parametru je parametr hlavního tagu <UL> , např. <!-- %ARCHIVE_YEAR(id="root")% -->, výsledek <UL id="root"> (režim weblog)

602.267 (12.6.2006)
Nové
  • podpora FTP klienta ftp_wb.exe pro přenos souborů na internet přímo z programu
  • další změny se týkají režimu expert
  • <!-- %DATA_POSITION% --> zapíše umístění zboží v režimu přehledu, které je nutné pro funkci hledání. Použije se pokud se používá přihazování do košíku pomocí formuláře s funkcí AddToCart() a není použitá šablona pro detailní zobrazení zboží.
  • pro objednané množství menší než minimální se použije cena 2, která je vyšší než cena 1. Ukázka kódu šablony <FORM NAME=order ACTION="_kosik.htm" onSubmit="parent.AddToCart(this);"> ... ... <input type=hidden name=PRICE2 value="<!-- %PRICE2_WITHOUT_REAL% -->"> <input type=hidden name=LIMITS22 value="<!-- %PAR_NUM_1% -->"> ... ... </FORM>
Odstraněné chyby
  • <!-- %XML_POHODA% --> odstraněné atributy note a transport, které působily problém při načítání objednávek do programu POHODA

602.265 (29.4.2006)
Nové
  • změny se týkají režimu expert pokud není uveden jiný režim
  • u karty zboží je možné zadat do malého i velkého obrázku internetovou adresu (i pro e-shop)
  • <!-- %GROUP_LIST_TABLE()% --> seznam hlavních skupin v tabulce, volba zarovnání v parametru (left, right, center), akceptuje zadané obrázky
  • <!-- %L_GROUP_LIST_TABLE()% --> seznam podskupin v tabulce, volba zarovnání v parametru (left, right, center), akceptuje zadané obrázky
  • <!-- %PRICE2_STRING% --> cena 2 s DPH jako text (např. 12,-)
  • kontrola na minimální objednané množství a kontrola na násobky množství. Ukázka kódu šablony <FORM NAME=order ACTION="_kosik.htm" onSubmit="parent.AddToCart(this);"> ... <input type=hidden name=MIN_QUANTITY value="xx"> <input type=hidden name=MODULO_QUANTITY value="xx"> ... </FORM>
  • <!-- %XML_BEZMYSI% --> podpora pro vytvoření objednávky s přílohou HTML+XML pro import do programu BezMyši - košík druhá strana. V režimu e-shop se nastaví příloha v parametrech pošty
  • u odběratele je možné zadávat i dodací adresu (i pro e-shop). Do stávajících šablon se přidají formulářové pole s názvy
    • DA_nazev
    • DA_titul
    • DA_jmeno
    • DA_prijmeni
    • DA_ulice
    • DA_mesto
    • DA_PSC
  • v režimu weblog je možné změnit pořadí u rubrik abecedně podle jména rubriky

602.264 (17.2.2006)
Odstraněné chyby
  • SEO v expertu generovalo krátké názvy souboru sloupku. Opravené odkazy v souboru mapa.htm. Opravené odkazy u klíčových slov <!-- %CLASSED_IN()% --> a <!-- %SUBGROUPS()% -->
  • při použití dalších obrázků je zabezpečen převod názvu souboru s obrázkem na malá písmena. Pokud je obrázek v podadresáři je správně změněno opačné lomítko na klasické lomítko.

602.263 (5.2.2006)
Nové
  • klíčová slova v režimu weblog
    • <!-- %CONTENT_START_TO()% --> začátek bloku články do čísla (parametr)
    • <!-- %CONTENT_START_FROM()% --> začátek bloku články od čísla (parametr)
    • <!-- %COLUMN_START_TO()% --> začátek bloku sloupek do čísla (parametr)
    • <!-- %COLUMN_START_FROM()% --> začátek bloku sloupek od čísla (parametr)
    • <!-- %CATEGORY_LIST_START_TO()% --> začátek bloku kategorie do čísla (parametr)
    • <!-- %CATEGORY_LIST_START_FROM()% --> začátek bloku kategorie od čísla (parametr)
    • <!-- %HOME_PAGE% --> - odkaz na úvodní stranu
    • <!-- %SUBCATEGORY_LIST_START% --> začátek bloku podřízené kategorie
    • <!-- %SUBCATEGORY_LIST_END% --> konec bloku podřízené kategorie
    • <!-- %IS_ACTIVE()% --> pro aktivní rubriku zapíše parametr
    • <!-- %NOT_ACTIVE()% --> pro neaktivní rubriku zapíše parametr
    • <!-- %FILE_NOT_ACTIVE% --> pro neaktivní rubriku zapíše jméno souboru rubriky
    • <!-- %NAME_F_CHAR_NOT_ACTIVE% --> 1. znak jména rubriky jetliže není aktivní
    • <!-- %NAME_F_CHAR% --> 1. znak jména rubriky
    • <!-- %NAME_N_CHARS% --> jméno rubriky od druhého znaku
    • <!-- %ACTUAL_SUBCATEGORY_NAME% --> jméno aktuální rubriky
    • <!-- %ACTUAL_CATEGORY_NAME% --> jmeno aktuální nadřízené rubriky
    • <!-- %IS_0()% --> zobrazí parametr pro sudé články
    • <!-- %NOT_0()% --> zobrazí parametr pro liché články
  • režim e-shop
    • pokud se zadá délka údaje množtví v košíku 1. strany 0, nejde měnit objednané množství, ale pouze smazat položku košíku
  • klíčová slova v režimu expert
    • <!-- %DETAIL_FILE_IS_TYPE_X% --> - zapíše detail souboru pokud je nějaké provedení záložky x-y
    • <!-- %TYPE_1R()% -->
    • <!-- %TYPE_5R()% --> radio butony provedení 1-5, parametr je oddelovač mezi hodnotami
    • <!-- %PAGES_GOODS()% --> seznam stránek oddělení s parametrem odělovače
    • <!-- %CLASSED_IN()% --> stránka zatříděna ve skupinách - odkazy, parametr oddělovač
    • <!-- %SUBGROUPS()% --> oddělení se dále dělí na skupiny - odkazy, parametr oddělovač
    • <!-- %COUNT_ITEMS% --> počet položek v oddělení (na stránce přehledu)
    • <!-- %DET_DESCRIPTION_SEARCH% --> popis zboží bez HTML tágů. Pro soubor hledání, xml apod.
    • <!-- %IS_DETAIL_LAST_PAGE()% --> zapíše parametr pokud existuje předchozí detail zboží ve stejné kategorii
    • <!-- %IS_DETAIL_NEXT_PAGE()% --> zapíše parametr pokud existuje následující detail zboží ve stejné kategorii
    • <!-- %VIEW_GOODS_START_GROUPS_TIP()% --> začátek bloku zboží označené jako TIP. Parametr určuje maximální počet zobrazených položek
    • <!-- %VIEW_GOODS_START_GROUPS_1% --> začátek bloku zboží náležící do aktuální nadřízené skupiny - liché položky
    • <!-- %VIEW_GOODS_START_GROUPS_0% --> začátek bloku zboží náležící do aktuální nadřízené skupiny - sudé položky
  • režim expert
    • automatické uložení(po odeslání objednávky) a načtení (po otevření košíku) iniciál odběratele
    • při vyplnění náhledového obrázku se předvyplní i detailní obrázek
    • u zatřídění zboží lze přebrat i mezikategorii
    • SEO u kategorií zboží
    • při zálohování se vytvoří teplate.ini do adresáře zálohy
    • další dvě extra šablony
Odstraněné chyby
  • SEO v expertu generovalo krátké texty článku
  • přehlasované písmena a, o, e
  • <!-- %L_GROUP_LIST_HERE_UL()% --> vnořený tag <UL> je mezi <li> a </li>
  • oprava třídění toplistu při použití Java Scriptu
  • mapa.htm neobsahuje nepoužité katagorie a odkazuje do cílových stránek
  • při načtení template.ini souboru se nesprávně nastavilo jméno extra souboru (obsahovalo i cestu)
  • automatická změna kódu skupin na malé písmena

602.262 (11.11.2005)
Nové
  • klíčová slova v režimu weblog
    • <!-- %IS_DET()% --> zapíše obsah parametru pokud existuje detail článku
    • <!-- %HREF_DET_CONTENT% --> soubor s detailem článku pokud existuje, jinak zapíše znak #
    • <!-- %IS_HREF_DET_CONTENT% --> soubor s detailem článku pokud existuje, jinak nezapíše nic
    • <!-- %IS_IMAGE()% --> pokud existuje v přehledu článku náhledový obrázek/v detailu náhledový nebo detailní obrázek, tak zapíše parametr
    • <!-- %IS_IMAGE_P()% --> pokud existuje náhledový obrázek článku, tak zapíše parametr
    • <!-- %IS_IMAGE_D()% --> pokud existuje detailní obrázek článku, tak zapíše parametr
  • režim e-shop
    • zrychlené generování souboru pro hledání
    • popis karet v přehledových stránkách se generuje jako text a ne jako proměnná Java Scriptu. Snadné zaindexování do vyhledávačů typu Google, Seznam ...
  • klíčová slova v režimu expert
    • <!-- %PRICE2_WITHOUT_REAL% --> cena 2 bez DPH zapsaná jako číslo
    • <!-- %PRICE3_WITHOUT_REAL% --> cena 3 bez DPH zapsaná jako číslo. Využití pro stanovení ceny na základě objednaného množství. Ukázka kódu šablony <FORM NAME=order ACTION="_kosik.htm" onSubmit="parent.AddToCart(this);"> ... <input type=hidden name=PRICE value="<!-- %PRICE1_WITHOUT_REAL% -->"> <input type=hidden name=PRICE2 value="<!-- %PRICE2_WITHOUT_REAL% -->"> <input type=hidden name=LIMITS2 value="<!-- %PAR_NUM_1% -->"> <input type=hidden name=PRICE3 value="<!-- %PRICE3_WITHOUT_REAL% -->"> <input type=hidden name=LIMITS3 value="<!-- %PAR_NUM_2% -->"> ... </FORM> Limintní hranice pro přiřazení ceny 2 a 3 se zadává do proměnné LIMITS2 a LIMITS3
    • <!-- %VIEW_GOODS_START_GROUPS% --> začátek bloku pro karty spadající do aktuální nadřízené skupiny
    • <!-- %IS_NEW()% --> pokud se jedná o novinku zapíše se obsah parametru
    • <!-- %DISCOUNT()% --> pokud se jedná o slevu zapíše se obsah parametru
    • <!-- %IS_SALE()% --> pokud se jedná o výprodej zapíše se obsah parametru
    • <!-- %IS_SPECS()% --> pokud obsahuje provedení zapíše se obsah parametru
    • <!-- %IS_TIP()% --> pokud se jedná o tip zapíše se obsah parametru
    • <!-- %OLD_PRICE_STRING_IS% --> zapíše původní cenu, pokud je různá od 0 a současně je větší než cena 1 s DPH
    • <!-- %IS_OLD_PRICE()% --> zapíše parametr, pokud je původní cena různá od 0 a současně je větší než cena 1 s DPH
    • <!-- %IS_IMAGE()% --> zapíše parametr, pokud je náhledový obrázek zboží
    • <!-- %NOT_IMAGE()% --> zapíše parametr, pokud není náhledový obrázek zboží
    • <!-- %IMAGE_EXIST()% --> zapíše parametr, pokud není náhledový obrázek zboží, jinak zapíše malý obrázek
    • <!-- %DET_IMAGE_EXIST()% --> zapíše parametr, pokud není detailní obrázek zboží, jinak zapíše velký obrázek
    • <!-- %NOT_FIRST_PAGE% --> zapíše parametr, pokud se nejedná o první stránku přehledu zboží
    • <!-- %NOT_BOTTOM_PAGE% --> zapíše parametr, pokud se nejedná o poslední stránku přehledu zboží
    • <!-- %NO_TYPE_X% --> zapíše parametr, pokud není zadána žádná varianta zboží na kartě (záložka 6-10)
    • <!-- %IS_TYPE_X% --> zapíše parametr, pokud je zadána nějaká varianta zboží na kartě (záložka 6-10)
    • <!-- %IS_RELATED_FILE()% --> zapíše parametr, pokud je zadáno související zboží na kartě (záložka 2)
    • <!-- %IS_RELATED_FILE2()% --> zapíše parametr, pokud je zadáno související zboží na kartě (záložka 3)
    • <!-- %IS_RELATED_FILE3()% --> zapíše parametr, pokud je zadáno související zboží na kartě (záložka 4)
    • <!-- %BOOKMARK_2()% --> zapíše název záložky, pokud je něco na záložce 2 vyplněno
    • <!-- %BOOKMARK_3()% --> zapíše název záložky, pokud je něco na záložce 3 vyplněno
    • <!-- %BOOKMARK_4()% --> zapíše název záložky, pokud je něco na záložce 4 vyplněno
    • <!-- %BOOKMARK_6()% --> zapíše název záložky, pokud je něco na záložce 6 vyplněno
    • <!-- %BOOKMARK_7()% --> zapíše název záložky, pokud je něco na záložce 7 vyplněno
    • <!-- %BOOKMARK_8()% --> zapíše název záložky, pokud je něco na záložce 8 vyplněno
    • <!-- %BOOKMARK_9()% --> zapíše název záložky, pokud je něco na záložce 9 vyplněno
    • <!-- %BOOKMARK_10()% --> zapíše název záložky, pokud je něco na záložce 10 vyplněno
    • <!-- %BOOKMARK_11()% --> zapíše název záložky, pokud je něco na záložce 11 vyplněno
    • <!-- %BOOKMARK_12()% --> zapíše název záložky, pokud je něco na záložce 12 vyplněno
    • <!-- %BOOKMARK_13()% --> zapíše název záložky, pokud je něco na záložce 13 vyplněno
    • <!-- %TYPE_1% --> provedení záložky 6
    • <!-- %TYPE_2% --> provedení záložky 7
    • <!-- %TYPE_3% --> provedení záložky 8
    • <!-- %TYPE_4% --> provedení záložky 9
    • <!-- %TYPE_5% --> provedení záložky 10
    • <!-- %TYPE_IMG% --> další obrázky s popisem, záložka 11
    • <!-- %TABLE_1% --> jednosloupcová tabulka, záložka 12
    • <!-- %TABLE_2% --> dvousloupcová tabulka, záložka 13
    • <!-- %IS_TYPE_1()% --> zapíše parametr, pokud je vyplněna záložka 6
    • <!-- %IS_TYPE_2()% --> zapíše parametr, pokud je vyplněna záložka 7
    • <!-- %IS_TYPE_3()% --> zapíše parametr, pokud je vyplněna záložka 8
    • <!-- %IS_TYPE_4()% --> zapíše parametr, pokud je vyplněna záložka 9
    • <!-- %IS_TYPE_5()% --> zapíše parametr, pokud je vyplněna záložka 10
    • <!-- %IS_TYPE_IMG()% --> zapíše parametr, pokud je vyplněna záložka 11
    • <!-- %IS_TABLE_1()% --> zapíše parametr, pokud je vyplněna záložka 12
    • <!-- %IS_TABLE_2()% --> zapíše parametr, pokud je vyplněna záložka 13
    • <!-- %XML_MONEYS3% --> vytvoří XML přílohu pro načtení objednávky do programu Money S3. Vkládá se do šablony košíku 2. strana
    • recyklační poplatek (cena bez DPH) se může zadat do některého z číselných sloupců záložky 5. Hodnota sloupce se pak přiřadí do formuláře
      Ukázka kódu šablony <FORM NAME=order ACTION="_kosik.htm" onSubmit="parent.AddToCart(this);"> ... <input type=hidden name=RP value="<!-- %PAR_NUM_1% -->"> ... </FORM>
    • pokud je potřeba zadávat hodnotu provedení do okna, které se zobrazí až po přidání zboží do košíku použije se následující
      Ukázka kódu šablony <FORM NAME=order ACTION="_kosik.htm" onSubmit="parent.AddToCart(this);"> ... <input type=hidden name=SPECS value="<!-- %SPECS% -->"> ... </FORM>


Jak funguje

Jedná se o databázovou aplikaci, která na základě nastavení vytvoří soubory typu HTML, které obsahují údaje z databází, vzájemné propojení, případně algoritmy na práci elektronického katalogu (e-obchodu). Soubory HTML (pouze e-obchod) obsahují program v jazyce JavaScript, ktrerý umožňuje vytvořit interaktivní stránky (tvorba objednávky).


Jak používat nápovědu

Tato nápověda slouží jednak jako nápověda při práci s programem WebGen.cz a současně jako samostatná příručka k programu. S výhodou lze využít fulltextové vyhledávání.

Při práci s programem se kontextová nápověda se vyvolá klávesou F1.


WebGen.cz - antivirové programy

Zpomalení generování programu

Při současném použití antivirového programu se zapnutou rezidentní ochranou dojde k několikanásobnému prodloužení generování stránek. Příčinou je kontrola nově vznikajících souborů (*.HTM, *.js ...), které generuje program WebGen.cz.

Pro zrychlení práce je vhodné po dobu generování souborů zrušit rezidentní antivirovou kontrolu.


Instalace programu

Před vlastní instalaci programu doporučujeme uzavřít ostatní aplikace.
Po spuštění zkomprimovaného instalačního souboru webgencz602xx.exe (xx je číslo verze programu) se objeví okno na rozbalení instalačního programu. Adresář na rozbalení instalace je přednabídnut c:\temp.
Pokud z jakýchkoliv důvodů potřebujete změnit tento adresář použijte pouze krátké jednoslovné názvy adresáře.

Po potvrzení tlačítka Start začne rozbalování instalačního programu do zvoleného adresáře a následně se spustí vlastní instalační program setup.exe

Pro pokračování v instalaci se potvrdí tlačítko další. Objeví se okno s přednastaveným adresářem pro vlastní instalaci.

Pokud není důvod jej měnit pokračuje se tlačítkem další.

Dále následuje okno s výběrem složky.

Tlačítkem Další se objeví konečné nastavení parametrů instalace.

Tlačítkem Další se zahájí vlastní instalační proces.

Na závěr instalace se objeví okno potvrzující ukončení instalace

V záložce WebGen.cz se vytvoří ikony pro spuštění programu WebGen.cz

Popis ikon

  • 602SQL Server - server 602SQL, spustí se automaticky spolu s aplikací. Samostatně se nespouští
  • Konfigurace 602SQL - konfigurace 602SQL, za normální situace není důvod spouštět a cokoliv měnit
  • Nápověda 602SQL - nápověda k prostředí 602SQL
  • WebGen.cz 602.xx - aplikace WebGen.cz verze 602.xx

Spuštění programu - přihlášení

Při spuštění programu se objeví okno pro přihlášení. Uživatel a heslo se nevyplňuje.


Weblog

Pro vygenerování stránek ve formátu weblogu je potřeba nastavit režim programu na weblog

V parametrech nastavení se doplní základní údaje

parametry_w.png, 14 kB
  • Adresa www stránek - celá URI adresa včetně http://
  • Externí HTML editor - oblíbený editor pro editaci šablon a HTML kódu článků
  • Nastavení šablon - uložení/nahrání/implicitní parametry konfigurace nastavení jednotlivých šablon. Používá se pro načtení jiné sady šablon, nebo uložení nově nastavených šablon.
  • Počet článků - počty zobrazených článků na úvodní straně a případně rubrice
  • Detail článku - text odkazu, který povede k detailu celého článku (pouze pro články, které obsahují detailní popis)
  • SEO - dlouhé názvy souborů - název souboru s detailem článku obsahuje název článku bez interpukčních znaků.
  • Formát datumu - volba zobrazení tvaru zobrazeného datumu (číslice, slovo, bez roku, s rokem ..)
Ostatní údaje se mohou nechat beze změny. Základní šablony se vytvoří automaticky.

Úprava šablony se provádí v externím editoru a vyvolá se tlačítkem [image]. Význam klíčových slov použitých v šablonách je popsán samostatně. Omezením v úpravě a výrobě šablony je délka řádku maximálně 255 znaků.

Nová šablona se nalistuje tlačítkem

Vlastní příspěvky se vkládají pomocí článků.

Kde
  • Datum - datum zapsání článku
  • Autor - autor článku
  • Rubrika - rubrika, do které spadá článek (nemusí se použít)
  • Nadpis - nadpis článku
  • Obr. - obrázek na hlavní stránce
  • Obr. det. - obrázek v detailu článku (pokud není uveden, zobrazí se obr.)
  • Poř. - pořadí zobrazení článku v rámci jednoho dne
  • Skrýt - ukrytí (nezobrazení) článku
Základní text článku se vkládá do editačního pole níže, nebo pomocí externího editoru tlačítko "EE a".
Detailní (delší) text se vkládá pomocí interního (tlačítko "Detail článku") nebo externího (tlačítko "EE b") editoru.

Ostatní tlačítka
  • Autor - číselník autorů článku a jejich e-mailových adres
  • Rubriky - číselník rubrik
  • Vložit - nový článek
  • Zrušit záznam - smazání článku
  • OK - uložení změn a zavření okna s články
  • Odvolat změny - uzavření okna s články bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Při použití rubrik

rubriky_red.png, 7 kB

se zadává
  • Jméno rubriky - označení rubriky
  • Soubor HTML - jméno stránky s rubrikou
  • Pořadí- pořadí zobrazení rubrik (pokud se použije klíčové slovo pro zobrazení obsahu rubrik)
  • Alternativní popis- popis, který se zobrazí v bublině, při najetí myši na text odkazu
  • Nadřízená rubrika - jméno nadřízené rubriky. Musí se použít v případě dvouúrovňového členění rubrik - využívají se nadřízené rubriky
  • SUBCATEGORY_TEXT_1 - HTML text, který se zobrazí na stránce v místě, kde je umístěné klíčové slovo <!-- %SUBCATEGORY_TEXT_1% -->

Při použití nadřízených rubrik

rubriky_nad.png, 6 kB

se zadává
  • Jméno rubriky - označení rubriky
  • Soubor HTML - jméno stránky s rubrikou
  • Alternativní popis- popis, který se zobrazí v bublině, při najetí myši na text odkazu
  • Pořadí- pořadí zobrazení rubrik (pokud se použije klíčové slovo pro zobrazení obsahu rubrik)
  • CATEGORY_TEXT_1 - HTML text, který se zobrazí na stránce v místě, kde je umístěné klíčové slovo <!-- %CATEGORY_TEXT_1% -->

Pro doplnění obsahu stránky (např. dalším sloupcem textu) je možné použít sloupek.

Jednoduchá forma nadpisu a krátkého textu je možná doplnit detailem, kdy se pro zobrazení celého detailu zobrazí samostatná stránka.

Pro generování samostatných stránek, které se zobrazí po kliknutí na jejich odkaz slouží nezávislé stránky.

Zadává se titulek (nadpis) stránky, jméno souboru (bez použití velkých písmen a českých znaků) a vlastní text pomocí interního (tlačítko "Editovat") nebo externího (tlačítko "EE a") editoru.

Pokud potřebujeme v kódu šablony zapsat text, který je delší než 255 znaků na řádku, použijeme tzv. dlouhé texty.

kde vložíme takový text a do šablony se vloží příslušné klíčové slovo.

A nyní již stačí stránky vygenerovat (CTRL+F9), podívat se na výsledek (F9) a pokud je vše v pořádku stránky nakopírovat na web.
Klíčová slova


Expert

Režim expert umožňuje generovat aplikace typu

  • e-shop
  • e-katalog
  • prezentační stránky
  • atp
s plnou kontrolou nad vzhledem aplikace pomocí šablon.

Pro vygenerování stránek v režimu expert je potřeba provést nastavení režimu

V parametrech nastavení se doplní základní údaje

parametry_e.png, 14 kB
  • Externí HTML editor - oblíbený editor pro editaci šablon a HTML kódu článků
  • Malé, velké obrázky - adresáře, kde jsou uloženy obrázky pro karty zboží. Pokud se změní adresáře je potřeba upravit šablony pro přehled a detail zboží
  • Samostatný detail - pro zobrazení detailních údajů o kartě je použit buď pro každou kartu samostatný soubor (výhodnější pokud je popis rozsáhlejší), nebo jeden dynamický pro všechny
  • Nastavení šablon - uložení/nahrání konfigurace nastavení jednotlivých šablon. Používá se pro načtení jiné sady šablon, nebo uložení nově nastavených šablon.
  • Počet článků - počet zobrazených článků na úvodní straně
  • SEO - dlouhé názvy souborů - název souboru s detailem článku a karty obsahuje název článku/karty bez interpukčních znaků. Pracuje pouze v režimu Samostatný detail
  • Detail článku - text odkazu, který povede k detailu celého článku (pouze pro články, které obsahují detailní popis)
  • Počet položek zboží na straně - počet položek zobrazených na jedné straně
  • Počet znaků popisu zboží pro vyhlédávání - počet znaků z popisu zboží, které budou zaindexované v souboru pro hledání
  • Formát datumu - volba zobrazení tvaru zobrazeného datumu (číslice, slovo, bez roku, s rokem ..)
  • Počet desetinných míst - počet platných zobrazených desetinných míst u ceny

Pro soubor hledání a přihlášení lze nastavit vlastní koncovku. Pokud není zadáno nic doplní se společná koncovka.

Ostatní údaje se mohou nechat beze změny. Základní šablony se vytvoří automaticky.

Úprava šablony se provádí v externím editoru a vyvolá se tlačítkem [image]. Význam klíčových slov použitých v šablonách je popsán samostatně. Omezením v úpravě a výrobě šablony je délka řádku maximálně 255 znaků.

Nová šablona se nalistuje tlačítkem

Vlastní příspěvky na úvodní straně se vkládají pomocí článků.

Kde
  • Datum - datum zapsání článku
  • Autor - autor článku
  • Nadpis - nadpis článku
  • Obr. - obrázek na hlavní stránce
  • Obr. det. - obrázek v detailu článku (pokud není uveden, zobrazí se obr.)
  • Poř. - pořadí zobrazení článku v rámci jednoho dne
  • Skrýt - ukrytí (nezobrazení) článku
Základní text článku se vkládá do editačního pole níže, nebo pomocí externího editoru tlačítko "EE a".
Detailní (delší) text se vkládá pomocí interního (tlačítko "Detail článku") nebo externího (tlačítko "EE b") editoru.

Ostatní tlačítka
  • Autor - číselník autorů článku a jejich e-mailových adres
  • Vložit - nový článek
  • Zrušit záznam - smazání článku
  • OK - uložení změn a zavření okna s články
  • Odvolat změny - uzavření okna s články bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Pro doplnění obsahu stránky (např. dalším sloupcem textu) je možné použít sloupek.

Jednoduchá forma nadpisu a krátkého textu je možná doplnit detailem, kdy se pro zobrazení celého detailu zobrazí samostatná stránka.

Pro generování samostatných stránek, které se zobrazí po kliknutí na jejich odkaz slouží nezávislé stránky.

Zadává se titulek (nadpis) stránky, jméno souboru (bez použití velkých písmen a českých znaků) a vlastní text pomocí interního (tlačítko "Editovat") nebo externího (tlačítko "EE a") editoru.

Pokud potřebujeme v kódu šablony zapsat text, který je delší než 255 znaků na řádku, použijeme tzv. dlouhé texty.

kde vložíme takový text a do šablony se vloží příslušné klíčové slovo.

Při využití levého okna rámu pomůžou "odkazy z levého rámu"

Pracují podobně jako nezávislé stránky s tím, že při použití klíčového slova <!-- %LINKS_LEFT_LIST% --> se vygeneruje seznam odkazů na tyto stránky. Sloupec
  • Existuje
    • - se použije pokud je potřeba vytvořit odkaz na již existujicí stránku
  • Pořadí
    • - určuje pořadí zobrazí odkazu za sebou
Stejně tak pracují odkazy z horního rámu

při použití klíčového slova <!-- %LINKS_TOP_LIST% --> se vygeneruje seznam odkazů na tyto stránky.

Pro zobrazení údajů z tabulky zboží v přehledu

slouží klíčové slova uvedená mezi <!-- %VIEW_GOODS_START% --> <!-- %VIEW_GOODS_END% -->, spolu s vložením <!-- %SC_P_GOODS% --> a <!-- %DATA_GOODS% -->, které se umístí do hlavičky stránky.

Ke kartě je možné přiřadit tři skupiny souvisejících položek (podobné, náhradní varianty, příslušenství ...). V detailu karty se lze pak na tyto karty odvolat.
Každá skupina má samostatnou šablonu.

Pro přiřazení hlavičky, patičky, pravého sloupce, pro konkrétní

skupinu zboží se použije <!-- %HEAD_PAGE% -->, <!-- %FOOT_PAGE% -->, <!-- %COLUMN_PAGE% -->.

K zobrazení seznamu odkazů skupin je <!-- %GROUP_LIST% --> a podskupin <!-- %L_GROUP_LIST% -->.

Pro vytvoření aplikace s funkcí e-katalogu je potřeba použít <!-- %SC_E_CATALOG% --> do souboru index.

K rozšíření na e-shop se soubor index doplní o <!-- %SC_E_SHOP% -->. V parametrech se nastaví základní iniciály

a další parametry pro chování e-shopu (úhrada, doprava, sazby a hranice, třídění).

Pro vyhledávání je potřeba do šablony hledání doplnit <!-- %SEARCH_DATA% --> nebo <!-- %SEARCH_DATA_PHP% --> podle použité metody (JavaScript nebo PHP).

A nyní již stačí stránky vygenerovat (CTRL+F9), podívat se na výsledek (F9) a pokud je vše v pořádku stránky nakopírovat na web.
Klíčová slova


Fotogalerie

Volba režimu programu je nastavena na režim fotogalerie

Tento režim je určený pro generování fotoalba z již připravených obrázků, nic se neukládá do databáze programu.

fotogalerie.gif, 13 kB

Popis údajů

  • Styl - výběr vzhledu fotogalerie
  • HTML stránky - složka, do které se buou generovat HTML soubory
  • Malé obrázky - složka, do které je potřeba nakopírovat náhledy
  • Velké obrázky - složka, do které je potřeba nakopírovat detailní obrázky
  • Jméno fotoalba - text pro pojmenování fotoalba
  • Postup zobrazení - hodnota v sekundách. Doba, po které so zobrazí následující detailní obrázek (uplatní se pouze v některém stylu )
  • Počet náhledů na straně - počet náhledových obrázků na jedné straně
  • Jména souborů na malé písmena - názvy souborů se načtou/nenačtou s automatickou změnou na malé písmena. Má vliv hlavně při umístění na internetu, kde se rozlišují velká a malá písmena
  • Použité šablony - jména souborů, které jsou použité jako "matrice" pro generování fotoalba. Umístění šablon je shodné s umístěním HTML stránek. Změnou těchto šablon se docílí změna vzhledu vygenerovaného fotoalba. Použitá klíčová slova jsou shodné s režimem Expert

Pro hromadnou změnu obrázků (vytvoření náhledů a velkých obrázků) jde např. použít program Irfan View, který je zdarma.
Šířka náhledových obrázků bývá okolo 100 obrazových bodů
Šířka velkých obrázků bývá okolo do 640 bodů

Více možností včetně popisu k obrázkům umožňuje režim Expert


HTML

  • <B></B> nebo <STRONG></STRONG> tučný text
  • <I></I> kurzíva
  • <U></U> podtržený text
  • <P></P> odstavec
  • <STRIKE></STRIKE> přeškrtnutý text
  • <CENTER></CENTER> centrování
  • <BR> konec řádku
  • <HR> vodorovná čára
  • &lt; znak <
  • &gt; znak >
  • &amp; znak &
  • &quot; znak “
  • &sect; znak §
  • &copy; znak ©
  • &nbsp; mezera
  • <H6 ALIGN=""></H6> nadpis
    • H1 - H6 - 1 největší písmo
    • ALIGN - zarovnání: LEFT - vlevo, CENTER - střed, RIGHT -vpravo
  • <A HREF="" TARGET=""></A> odkaz
    • HREF - soubor, který se má otevřít
    • TARGET - cílové okno
      • _top - okno s nejvyšší prioritou
      • _parent - nadřízené okno
      • _self - aktuální okno
      • _blank - nové okno
  • <IMG SRC="" WIDTH= HEIGHT= ALT="" ALIGN="" BORDER= VSPACE= HSPACE=> obrázek
    • SRC - cesta a jméno obrázku
    • WIDTH - šířka obrázku
    • HEIGHT - výška obrázku
    • ALIGN - zarovnání obrázku
      • LEFT
      • RIGHT
      • TOP
      • TEXTTOP
      • MIDDLE
      • ABSMIDDLE
      • BASELINE
      • BOTTOM
      • ABSBOTTOM
    • BORDER - šířka okraje 0=žádný
    • VSPACE - svislé odsazení
    • HSPACE - vodorovné odsazení
  • <FONT FACE="" SIZE="" COLOR=""></FONT> font
    • FACE - jméno fontu
    • SIZE - velikost fontu 1-malý, 7-velký nebo + či - a číslo
    • COLOR - barva fontu
  • <TABLE>
    <TR><TD>text </TD><TD>text</TD></TR>
    <TR><TD>text </TD><TD>text</TD></TR>
    </TABLE> tabulka
    parametry <TABLE >
    • BORDER - šířka okraje v pixelech
    • CELLSPACING - mezera mezi dvěma buňkami v pixelech
    • CELLPADDING - mezera mezi buňkou a okrajem v pixelech
    • WIDTH - šířka tabulky v pixelech nebo procentech
    • ALIGN zarovnání tabulky
      LEFT, CENTER, RIGHT
    • FRAME - typ ohraničení tabulky VOID, ABOVE, BELOW, HSIDES, LHS RHS, VSIDES, BOX
    • RULES - typ ohraničení tabulky NONE, GROUPS, ROWS, COLS, ALL
    • BGCOLOR -barva tabulky
Detailnější popis jak na HTML stránky najdete na internetu např. na http://www.jakpsatweb.cz


Záloha dat

Záloda datových souborů do zvoleného adresáře v interním formátu Winbase602.

Nezálohují se obrázky a šablony!

Obnova dat


Parametry zálohy

Nastavení adresáře, do kterého se provádí záloha dat. Data jsou uložena do souborů ve vnitřím formátu Winbase602.

Záloha dat Obnova dat


Obnova dat

Obnova dat ze zálohy - vybraného adresáře.

Pozor původní data se přepíšou. Doporučujeme před obnovou dat provést zálohu do jiného adresáře.
Pomocí zálohy a obnovy dat se provádí přechod na jinou verzi programu.
Záloha dat


Import z DBF

Načtení dat (karty zboží, výrobků, služeb) z DBF souboru do aplikace.

Funkce umožňuje načíst data ze souboru DBF do tabulky Zboží podle nastaveného předpisu.
Nastavený přenos jde uložit pro další použití.

Spárování sloupců tabulek:
- v pravé části okna se myší vybere(levé tlačítko) sloupec z DBF souboru
- tlačítkem [image] se provede přiřazení k příslušnému sloupci tabulky zboží
- anebo se název sloupce přímo zapíše

Volby

Formát DBF souboru:
  • dBase 4
  • FoxPro 2
Kódování:
  • Windows EECS
  • Kamenických
  • Latin 2
Způsob importu:
  • Přidat vše
  • Přidat nové
  • Přepsat vše
  • Aktualizovat. Sloupec kód musí být v tomto případě jednoznačný.
Import - export


Přenosy dat mezi dvěma zdroji

WinBase602 obsahuje univerzální nástroj na přenášení dat mezi řadou datových formátů podle popisu zadaného uživatelem nebo automaticky odvozeného ze struktury dat.

Využití
  • přenos dat z prostředí WinBase602 ven (Export dat),
  • přenos dat z jiného prostředí do tabulky WinBase602 (Import dat),
  • přenos z tabulky WinBase602 do jiné tabulky s případnými změnami hodnot,
  • úpravu tabulek a záznamů v jedné tabulce WinBase602 (Modifikace dat):
  • zkušenějším uživatelům jsou k dispozici obecné přenosy z jednoho prostředí do prostředí jiného včetně přenosů z (do) zdroje dat připojeného přes rozhraní ODBC.
Návrhář přenosu dat
Návrhář přenosu dat dovoluje nejprve popsat způsob přenosu a poté data přenést. Po doběhnutí přenosu lze buď návrh přenosu zapomenout, anebo jej lze uložit do databáze pro pozdější použití. Navržený přenos je pak uložen mezi programy a lze jej opětovně provést vyvoláním akce Spustit.

Postup návrhu přenosu
Okno návrháře přenosu se skládá ze čtyř očíslovaných částí. Při návrhu se postupuje shora dolů podle následujícího popisu:

1. Stanovíte Odkud vzít data pro přenos. V levém combu nejprve vyberete druh zdroje dat a pak vpravo:
  • zvolíte buď jeden z nabízených objektů (tabulku z WinBase602 nebo z cizího zdroje dat, odpověď na dotaz),
  • nebo tlačítkem otevřete okno pro volbu vstupního souboru.
2. Stanovíte Kam zapisovat přenášená data. V levém combu nejprve vyberete druh cílového objektu a pak vpravo:
  • buď zvolíte některý nabízený objekt (existující tabulku ve WinBase602 nebo v cizím zdroji dat);
  • nebo zadáte jméno tabulky, která se má vytvořit;
  • anebo tlačítkem otevřete okno pro zadání výstupního souboru (vyberete-li exitující soubor, přenos dat jej - po dotazu - přepíše);
3. Doplníte Detailní popis přenosu jednotlivých hodnot. Tento popis se nevyplňuje, pokud přenášíte do nebo ze souboru ve vnitřním formátu WinBase602 (export / import dat ve vnitřním formátu). Automatický počáteční návrh přenosu lze vytvořit stiskem tlačítka Vytvořit popis. Obsah detailního popisu závisí na tom, odkud a kam přenášíte - viz dále.

4. Zadáte případnou podmínku, kterou musí splnit přenášené záznamy. Pomocí této podmínky lze filtrovat pouze záznamy exportované z tabulky ve WinBase602 nebo z odpovědi na dotaz. Není-li podmínka zadaná, přenesou se všechny záznamy.

Poté tlačítkem Kontrola popisu můžete provést hrubou syntaktickou kontrolu popisu a tlačítkem Přenést data zahájit vlastní přenos. Průběh přenosu lze sledovat na stavové řádce. Stiskem tlačítka Uložit popis se definice tohoto přenosu dat uloží jako speciální typ programu pro další použití.

Textový formát

Při přenosu ze souboru CSV vytvořeného např. v excelu je potřeba přenastavit oddělovač polí na ;. Po vytvoření souboru CSV se tento soubor nesmí v excelu otevřít protože již nejde pro přenos použít.

Podrobnosti přenosu dat jsou popsány v nápovědě dostupné v okně přenosu dat.
Import z DBF


Kontrola databáze

Kontrola a případná oprava databázového souboru. Doporučujeme spustit po nelegálním ukončení programu.


Velikost souboru

Zvětšení databázového souboru. Používá se po té, co se při spuštění serveru (aplikace) objeví hlášení o nedostatku volných clusterů. Program nabídne současnou velikost, která se upraví (směren nahoru).


Konec programu

Ukončení práce s programem WebGen.cz. Současně se ukončí aplikace WebGen.cz a WinBase602 server. Klávesa ALT+F4.
Horké klávesy


Karty

Pořízení, editace a mazání karet. Klávesa CTRL+K

Přehledové okno, které zobrazuje některé vybrané sloupce, umožňuje vybrat množinu záznamů pomocí filtru, setřídění podle zvoleného sloupce (poklepáním na název sloupce).

Popis tlačítek

  • Detail - zobrazí detailní informace o vybrané kartě (obdoba - poklepání na řádku)
  • Obrázek - zobrazí náhledový obrázek k vybrané kartě
  • Smazat kartu - smaže vybranou kartu
  • OK - uzavření okna s uložením změn
  • Odvolat změny - uzavření okna bez uložení změn
  • Zruš filtr - zruší nastavený filtr a zobrazí všechny karty
Klávesou Insert se dostaneme na pořízení nové karty.
Oblast okna nazvaná filtr slouží k výběru podmnožiny podle jednoho nebo více zadaných údajů. U textových údajů (kód, název, výrobce) stačí zadat začátek slova.U číselných údajů (SK, PSK, cena s DPH, Top) se zadává celý údaj.U označovacího čtverce (nové, tip, sleva, provedení, skrýt) mohou nastat tři stavy. Čtverec může být zaškrtnut nebo nezaškrtnut případně může mít nedefinovanou hodnotu.
POZOR pokud použijeme ve filtru označovací čtverec, pro ukončení filtru použijeme tlačítko Zruš filtr.

Detail karty

Popis sloupců

  • Kód - kódové označení karty
  • Skup. - číselný kód skupiny, v detailu se zobrazí název skupiny a pro zatřídění se použije tlačítko Zatřídění nebo jde použít hromadné zatřídění
    Lze zatřídit současně do šesti skupin.
  • Název - název karty (80 znaků)
  • Výrobce - název výrobce. Po prvním použití je v další kartě výrobce dostupný v combu. Otevření comba (nabídky) se provede myší nebo klávesou alt+šipka dolů
  • DPH - procento DPH *
  • Cena bez DPH - *
  • Cena s DPH - koncová prodejní cena
  • Cena 1 - základní prodejní cena
  • Cena 2, Cena 3 - další ceny, které se zobrazí po přihlášení
  • Stará cena - v případě, že koncová cena se změní, může se zde uvést pro srovnání původní cena
  • Malý obrázek -- jméno souboru. Pro nalistování souboru použijeme tlačítko Malý obr. nebo pravé tl. myši. Pravidla pro jména souboru
  • Velký obrázek -- jméno souboru. Pro nalistování souboru použijeme tlačítko Velký obr. nebo pravé tl. myši. Pravidla pro jména souboru
  • Toplist - pořadí v prodeji. Karty označené pořadovým číslem se jednak dostanou do skupiny nazvané Toplist a současně se podle nastavení mohou objevit na úvodní straně v pravém sloupku.
  • Novinka - příznak pro novou kartu. Karta se dostane do skupiny nazvané Novinky a současně se podle nastavení objeví text u karty.
  • Tip - příznak označující kartu jako tip. Karta se dostane do skupiny nazvané Tipy a současně se bude zobrazovat na úvodní straně. Pokud se označí více karet, tak na úvodní straně se zobrazí vždy náhodně pouze jedna karta.
  • Sleva - karta se do skupiny nazvané Sleva
  • Provedení - označená karta bude při objednání vyžadovat doplnění dalších údajů(např. barva, velikost podle nastavení)
  • Skrýt - karta se nezobrazí na stránkách aplikace
  • Výprodej - označená karta se objeví ve skupině nazvané Výprodej
  • Popis - popis karty. Může obsahovat HTML kód. Zobrazí se volitelně v přehledu nebo detailu.
  • Detailní popis - detailní popis karty. Může obsahovat HTML kód. Zobrazí se volitelně v detailu.

Další popis záložek platí jem pro režim expert a licenci WebGen.cz Pro

* - platí pro plátce DPH viz. nastavení

Import z DBF Import - export Hromadné zatřídění Názvy sloupců Názvy záložek Záložky


Nastavení pohledu

Volba zobrazených sloupců tabulky Zbozi.

Umožňuje libovolně zvolit sloupce, které se zobrazí v databázové mřížce. Sloupce se přesunují poklepáním na název sloupce.
Vlastní pohled Tabulky


Vlastní pohled

Nastavit lze až sedm uživatelských pohledů na tabulku karty

Sloupec (údaj), který chceme zobrazit označíme číslem. Hodnota čísla udává pořadí jednotlivých zobrazených sloupců.

Zobrazení tabulky s vlastním pohledem klávesa CTRL+1 až CTRL+8 (horké klávesy)

Obecně platné funkce pro data zobrazené v datové mřížce.
  • Změna pořadí sloupců - levým tlačítkem myši uchopit a přetáhnout název sloupce
  • Zrušení zobrazení sloupce- levým tlačítkem myši kliknout na název sloupce (sloupec se označí) a a klávesou delete se sloupec odstraní
  • Změna třídění - dvojklik ma název sloupce (opětovný dvojklik provede opačné třídění)


Přepočet cen s DPH

Přepočítá u všech karet ceny s DPH na základě ceny bez DPH. Pokud není vyplněna sazba DPH (u plátce) dosadí se implicitní hodnota DPH (viz. Sazby - hranice)

Přepočet cen bez DPH


Přepočet cen bez DPH

Přepočítá u všech karet ceny bez DPH na základě ceny s DPH. Pokud není vyplněna sazba DPH (u plátce) dosadí se implicitní hodnota DPH (viz. Sazby - hranice).

Přepočet cen s DPH


Kódy speciálních skupin

Přiřazení kódu skupin k vybraným položkám.

Do těchto skupin se přiřadí karty označené příslušným příznakem.

Karty Skupiny Zatřídění


Skupiny

Pořizování, editace, mazání skupin.

Počet úrovní skupin není omezen.

Popis údajů

  • Kód - jednoznačné označení skupiny. Nepoužívat české, speciální znaky a mezery v kódu. Pokud je rozpad této skupiny nejde měnit kód. Kódy speciálních skupin jsou dostupné zde.
  • Název - název skupiny. Text, který se zobrazí jako odkaz na skupinu (pokud není vyplněn obrázek).
  • Pořadí - pořadí zobrazení skupiny
  • Má rozpad - existuje/neexistuje podřízená skupina
  • Další - přechod do podřízené skupiny

Karty Skupiny - texty Skupiny - spec. kódy Zatřídění


Skupiny - texty

Pořizování, editace textu a dalších údajů spojených se skupinou.

Popis editovatelných údajů

  • Obrázek - soubor s obrázkem. Nalistování obrázku - pravé tl. myši. Pokud je obrázek vyplněn a je nastavené grafické zobrazování skupin, zobrazí namísto textového odkazu.
  • Titulek - bublina - popis skupiny. Při najetí myší na obrázek se zobrazí tento text.
  • Záhlaví 1. strany - text zobrazený v záhlaví hlavního okna této skupiny
  • Záhlaví další strany - text zobrazený v záhlaví hlavního okna této skupiny na 2. a další straně
  • Zápatí 1. strany - text zobrazený v zápatí hlavního okna této skupiny
  • Zápatí další strany - text zobrazený v zápatí hlavního okna této skupiny na 2. a další straně
  • Pravý sl. 1. strany - text zobrazený v pravém sloupci hlavního okna této skupiny
  • Pravý sl. další strany - text zobrazený v pravém sloupci hlavního okna této skupiny na 2. a další straně
  • Záhlaví oddělení - text zobrazený v záhlaví levého rámu této skupiny
  • Zápatí oddělení - text zobrazený v zápatí levého rámu této skupiny
  • Nahradit - nahrazení/přidání textu k standardnímu záhlaví/zápatí

Karty Skupiny - pořízení Zatřídění


Zatřídění

Okno zobrazuje položky, které nepatří do skupiny . Zatržené položky (sloupec označ) se hromadně dosadí do zvolené skupiny (podskupiny). Výběr dostupných skupin a podskupin se zobrazí po stisknutí tlačítka výběr skupin.

Tlačítkem Převzít se skupina dosadí do označených karet .

Skupiny Karty


Tabulka uživatelů

Definice uživatelů pro zpřístupnění ceny 2 a ceny 3

Popis sloupců

  • Jméno uživatele - jméno zadávané při přihlášení
  • Heslo - heslo zadávané při přihlášení
  • Cena - přiřazení ceny 2 nebo 3
  • Poznámka -

Přihlašovací formulář Názvy cen


Názvy cen

Pojmenování cen, definice akcí po přihlášení

Popis údajů

  • Název - pojmenování ceny 1-6
  • Měna - zkratka měny
  • Kurz - kurz pro přepočet ceny (včetně distribučních nákladů). Výchozí cena je cena1. Platí pro cenu 4-6
  • Koeficient - kurz pro přepočet cen (bez distribučních nákladů). Výchozí cena je cena1. Platí pro cenu 4-6
Pro zobrazení názvu, měny, kurzu, koeficientu na stránkách slouží následující kód:

  • Úspěšné přihlášení - funkce JavaScriptu, ktrá se provede po úspěšném přihlášení
  • Neúspěšné přihlášení - funkce JavaScriptu, ktrá se provede po neúspěšném přihlášení
    Přihlašovací formulář Uživatelé


Přihlášení

Deklarace formuláře pro přihlášení

Definice souboru s názvem log.htm, který obsahuje formulář pro přihlášení.
Pro vyvolání stránky log.htm je nutné umístit někde odkaz na tento soubor.
Horní rám odkazy - zatrhnout údaj existuje
Levý rám odkazy - zatrhnout údaj existuje
Kdekoliv jinde do HTML kódu podle potřeby.
Přihlašovací jméno:
Heslo

Uživatelé Názvy cen


 tabulky karty skupiny psk


Horní rám - odkazy

Pořízení, editace a mazání odkazů vrchního rámu.

Popis údajů

  • Text odkazu - textový odkaz (nezobrazí se pokud je použit obrázek)
  • Obrázek - jméno souboru s obrázkem. Pravé tl. myši nalistuje soubor. Nemusí se použít.
  • Alternativní text - popis obrázku po najetí myši na obr.
  • Soubor - jméno HTML souboru, na který ukazuje odkaz. Pokud je zatržený údaj existuje musí soubor fyzicky existovat. Pokud není zatrženo existuje - WebGen ho vytvoří. Soubor by měl být malým písmem, bez českých a specialní znaků, bez mezer a s příponou .htm, .html apod..
  • Existuje - příznak zda soubor fyzicky existuje nebo nikoliv.
  • Nové okno - odkaz se zobrazí do stávajícího hlavního okna, nebo se otevře nové (další) okno.
  • Skrýt - takto označený odkaz se nezahrne do HTML stránek.
  • Obsah - vlastní obsah HTML stránky (odkazu). Je přístupný pokud není údaj existuje zatržen. Může obsahovat libovolný html kód.
  • Odkaz na úvodní stranu - definice odkazu na úvodní stranu
  • Odkaz na nákupní košík - definice odkazu na nákupní košík a odeslání objednávky

Tlačítka

  • EEa - externí editor pro editaci textu odkazu
  • Nový - založí nový odkaz
  • Smazat - smaže odkaz
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Horní rám - parametry


Horní rám, obrázky nastavení

Definice velikosti a obrázků vrchního rámu.

Střední část horního rámu - střed rámu nad odkazy
Obrázek - jméno souboru s obrázkem. Nebude-li údaj vyplněn, zobrazí se textový údaj - jméno obchodu (viz. nastavení). Nalistování souboru - pravé tl. myši.
Alternativní popis - popis obrázku (po najetí myší). Má význam pouze s kombinací s obrázkem.

Logo - levá část horního rámu
Obrázek - jméno souboru s obrázkem. Nalistování souboru - pravé tl. myši.
Alternativní popis - popis obrázku (po najetí myší). Má význam pouze s kombinací s obrázkem.

Symbol objednáno - pravá část horního rámu
Obrázek - jméno souboru s obrázkem. Nebude-li údaj vyplněn, zobrazí se textový údaj - Objednáno za. Nalistování souboru - pravé tl. myši.
Alternativní popis - popis obrázku (po najetí myší). Má význam pouze s kombinací s obrázkem.

Výška vrchního rámu - výška rámu v bodech (např.150), nebo v procentech celkové výšky obrazovky (např. 25%)

Vlastní definice umožní vytvořit vlastní obsah horního rámu.
Funkce dostupná při nastavení programu v režimu e-shop, e-katalog.


Odkazy - levý rám

Pořízení, editace a mazání odkazů levého rámu.

Popis údajů

  • Text odkazu - textový odkaz (nezobrazí se pokud je použit obrázek)
  • Obrázek - jméno souboru s obrázkem. Pravé tl. myši nalistuje soubor. Nemusí se použít.
  • Alternativní text - popis obrázku po najetí myši na obr.
  • Soubor - jméno HTML souboru, na který ukazuje odkaz. Pokud je zatržený údaj Existuje musí soubor fyzicky existovat. Pokud není zatrženo Existuje - WebGen.cz ho vytvoří. Pravé tl. myši nalistuje soubor. Zásady pro vytváření jména souboru.
  • Pořadí - pořadí v jakém se odkazy zobrazí (shora dolů)
  • Existuje - příznak zda soubor fyzicky existuje nebo nikoliv.
  • Nové okno - odkaz se zobrazí do stávajícího okna, nebo se otevře nové (další) okno.
  • Skrýt - takto označený odkaz se nezahrne do HTML stránek.
  • Obsah - vlastní obsah HTML stránky (odkazu). Je přístupný pokud není údaj Existuje zatržen.Může obsahovat libovolný html kód.

Tlačítka

  • EEa - externí editor pro editaci textu odkazu
  • Nový - založí nový odkaz
  • Smazat - smaže odkaz
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Nastavení Texty


Levý rám - texty

Popis údajů

  • Vrchní text - text umístěný v horní části levého rámu. Může obsahovat libovolný HTML kód
  • Spodní text - text umístěný v dolní části levého rámu. Může obsahovat libovolný HTML kód

Popis tlačítek

  • Editovat vrchní text - otevře editor pro editaci vrchního textu
  • EE a - otevře externí editor pro editaci vrchního textu
  • Editovat spodní text - otevře editor pro editaci spodního textu
  • EE b - otevře externí editor pro editaci spodního textu
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Odkazy Parametry


Levý rám - nastavení

Nastavení vzhledu levého rámu.

Nadpis oddělení obchodu - textový údaj uvozující jednotlivá oddělení (skupiny a podskupiny).
Obrázek - jméno souboru s obrázkem. Pokud není údaj vyplněn zobrazí se nadpis viz. výše. Pravé tl. myši nalistování souboru.
Alternativní popis - popis obrázku po najetí myši na obrázek
Šířka levého rámu - šířka rámu v bodech (např.150), nebo v procentech celkové šířky obrazovky (např. 25%).
Odkazy před oddělením - zatržením budou odkazy zobrazeny nad oddělením (jinak naopak)
Vlastní deklarace oddělení - po zatržení se nebude generovat menu s nabídkou oddělení. Je nutné si vytvořit vlastní odkazy na jednotlivé oddělení
Textové odkazy + grafické symboly - definuje vzhled zobrazení skupin. Pokud je zatrženo jdou vidět grafické symboly + textové odkazy,

jinak buď textové nebo plně grafické odkazy.

Volba zarovnávání odkazů.
Odkazy Texty


Rubriky

Popis údajů

  • Jméno - jméno rubriky
  • Obrázek - soubor s obrázkem, objeví se místo Jména. Pravé tl. myši provede nalistování
  • Popis - popis obrázku v bublině
  • Soubor - jméno souboru, ve kterém bude rubrika uložena. Jméno se stanovuje podle pravidel.
  • Pořadí - pozice zobrazení rubriky na stránce
  • Nadřízená rubrika - jméno rubriky, která je nadřízenou pro tuto rubriku
  • Parametry tabulky - parametry tabulky zobrazující rubriky (orámování, šířka ...)
  • Zarovnání řádků - způsob zarovnání odkazů (vlevo, uprostřed, pravo)
  • Nadpis pro rubriky - textový údaj
  • Nebo obr. - soubor s obrázkem nahrazující textový nadpis
  • Odkaz na úvodní stranu - textový údaj
  • Nebo obr. - soubor s obrázkem nahrazující textový odkaz

Popis tlačítek

  • Nový - vložení nové rubriky
  • OK - uložení změn a zavření okna
  • Odvolat změny - odvolání změn a zavření okna
  • Nadřízené rubriky - otevření okna s nadřízenými rubrikami

Nadřízené rubriky

Popis údajů

  • Jméno - jméno nadřízené rubriky
  • Obrázek - soubor s obrázkem, objeví se místo Jména. Pravé tl. myši provede nalistování
  • Alternativní text - popis obrázku v bublině
  • Soubor HTML - jméno souboru, ve kterém bude nadřízená rubrika uložena. Jméno se stanovuje podle pravidel.
  • Pořadí - pozice zobrazení rubriky na stránce
  • Nadpis pro rubriky - textový údaj
  • Nebo obr. - soubor s obrázkem nahrazující textový nadpis


Levý sloupec Texty - nastavení

Popis údajů

  • Vrchní text - text umístěný v horní části levého sloupce. Může obsahovat libovolný HTML kód
  • Spodní text - text umístěný v dolní části levého sloupce. Může obsahovat libovolný HTML kód
  • Vkládat vrchní text do všech stránek - přepínač pro vkládání textu pouze do úvodní strany nebo do všech stránek
  • Vkládat spodní text do všech stránek - přepínač pro vkládání textu pouze do úvodní strany nebo do všech stránek
  • Šířka sloupce - nastavení šířky levého sloupce v bodech (např. 150), nebo v procentech celkové šířky obrazovky (např. 30%).

Popis tlačítek

  • Editovat vrchní text - otevře editor pro editaci vrchního textu
  • EE a - otevře externí editor pro editaci vrchního textu
  • Editovat spodní text - otevře editor pro editaci spodního textu
  • EE b - otevře externí editor pro editaci spodního textu
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy
Rubriky


Sloupek

Pořízení, editace, mazání článku ve sloupku. Klávesa CTRL+S (horké klávesy)

Sloupek je sloupec článků, které se zobrazují na úvodní straně na pravé části obrazovky. Pokud nepotřebujeme sloupek zobrazit, tak se pouze nevyplňuje žádný údaj.

Popis údajů

  • Nadpis článku - nadpis uvozující článek sloupku
  • Obsah - typ obsahu článku:
    • Dnešní datum - datum vygenerování (aktualizace) stránek. Používá se na zobrazení poslední úpravy stránek.
    • Toplist - seznam zboží (služeb), označených příznak toplist. Program vygeneruje seznam odkazů. Má význam pro nastavení v režimu e-shop
    • Text - libovolný text (program nic negeneruje)
  • Pořadí - pořadí v jekém budou články zobrazeny pod sebou.
  • Skrýt - zatržený článek se nezobrazí na stránce (lze později použít na rozdíl od smazání).
  • Šířka sloupku - šířka sloupku v bodech (např. 100), nebo v procentech šířky (30%)
  • Vlastní obsah článku sloupku - libovolný text včetně HTML kódu.

Tlačítka

  • EEa - externí editor pro editaci textu
  • Nový - založí nový článek
  • Smazat - smaže článek
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Články Záhlaví Střed Zápatí


Články

Pořízení, editace, mazání článku.

Klávesa CTRL+L (viz. Horké klávesy)

Údaje souboru

  • Datum - datum vytvoření článku (pokud se nevyplní na stránce se zobrazí bez údaje datum)
  • Autor - autor článku (není nutné vyplnit). Návaznost na číselník autorů.
  • Rubrika - jméno rubriky, do které článek spadá (nutno vyplnit při použití redakčního systému). Návaznost na číselník rubrik.
  • Nadpis - nadpis článku
  • Souvisí - jméno souboru, který navzájem prováže související články. Stejný název je potřeba napsat k těm článkům, které spolu souvisí. Jméno souboru bez českých znaků, malým písmem a bez mezer.
  • Pořadí - pořadí zobrazení článku nad sebou v rámci stejného datumu (není nutné vyplňovat).
  • Skrýt - zatržený článek se nezobrazí na stránkách (později lze použít)
  • Odkaz na soubor - soubor, na který odkazuje obrázek. Pravé tl. myši nalistování. Vyplňuje se pouze, pokud se tvoří odkaz z obrázku na jiný soubor než detail článku.
  • N. okno - příznak na otevření odkazu do nového okna.
  • Obrázek - soubor s obrázkem. Zobrazí se v horní části článku. Pravé tlačítko nalistování.
  • Alternativní text - popis obrázku po najetí kurzoru na obr..
  • Notace článku - úvodní část článku zobrazená v přehledu článků.

Tlačítka:

Zruš filtr - zruší zadaný filtr a zobrazí všechny údaje
Detail článku - celý obsah článku. Připojí se za notaci článku a zobrazí se spolu s obrázkem na samostatné stránce.
EEa - externí editor pro editaci notace článku
EEb - externí editor pro editaci detailu článku
Autor - číselník autorů
Rubriky - číselník rubrik
Nový - založení nového článku
Smazat článek - smaže vybraný článek
OK - uzavření okna a uložení změn
Odvolat změny - uzavření okna bez uložení změn
HTML ? - otevření okna se základními HTML tágy

Ostatní parametry

Počet článků na úvodní straně - definuje kolik nejnovějších článků se má zobrazit na úvodní straně
V rubrice - definuje kolik nejnovějších článků se má zobrazit v konkrétní rubrice, ostatní se objeví v archivu
V nadřízené rubrice - definuje kolik nejnovějších článků se má zobrazit na úvodní straně nadřízené rubriky


Záhlaví - zápatí úvodní strany

Hlavička a patička úvodní strany

Popis údajů

  • Záhlaví - text umístěný v horní části strany. Může obsahovat libovolný HTML kód
  • Střed - text umístěný ve střední části strany. Může obsahovat libovolný HTML kód
  • Zápatí - text umístěný v dolní části strany. Může obsahovat libovolný HTML kód

Popis tlačítek

  • Editovat záhlaví - otevře editor pro editaci záhlaví
  • EE a - otevře externí editor pro editaci záhlaví
  • Editovat střed - otevře editor pro editaci střední části
  • EE b - otevře externí editor pro editaci střední části
  • Editovat zápatí - otevře editor pro editaci zápatí
  • EE c - otevře externí editor pro editaci zápatí
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Články Sloupek


Nezávislé stránky

Stránky bez návaznosti na ostatní stránky.

Popis údajů

  • Popis souboru - titulek stránky
  • Jméno souboru - jméno vygenerovaného souboru, koncovka musí odpovídat koncovkám používaných v prohlížeči (htm, html ...)
  • Bez parametrů - stránka obsahuje/neobsahuje styl ostatních stránek vygenerovaných v programu. Pokud je zatrženo uživatel musí nadefinovat celou strukturu souboru.
  • Skrýt - soubor se nebude generovat
Odkaz na zobrazení takto vygenerované stránky musí uživatel vytvořit sám. Používá se např. na stránku, krerá se zobrazí odskokem z textu článku, popisu zboží, textu sloupku apod..
Tlačítka
  • Editovat obsah - otevře editor pro editaci textu stránky
  • EEa - externí editor pro editaci textu stránky
  • Nový - založí novou stránku
  • Smazat - smaže stránku
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy


Pravý sloupec

Parametry a vlastní obsah pravého sloupce

Režim e-shop, e-katalog

Popis údajů

  • Popis obsahu sloupce - poznámka k obsahu. Pro lepší orientaci, kde je definováno více textů.
  • Obsah - vlastní text. Může obsahovat libovolný HTML kód. Pro zobrazení obsahu sloupce z úvodní strany napište: <script src="pr_slrs.js" language="JavaScript"></script>
  • Pořadí - pořadí v jakém se bude text zobrazovat. Na každé straně se zobrazí vždy pouze jeden text.
  • Skrýt - údaj nebo generován
  • Použít pravý sloupec - přepínač pro aktivaci zobrazení pravého sloupce
  • Šířka sloupce - hodnota v bodech (100, 120, ...) nebo v procentech (30%, 35% ...)

Tlačítka

  • Editovat obsah - editor pro editaci textu sloupce
  • EEa - externí editor pro editaci textu
  • Nový - založí nový údaj
  • Smazat - smaže údaj
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy

Režim redakční systém

Popis odlišných údajů

  • Rubrika - jméno rubriky, kde se bude text zobrazovat. Pokud se neuvede zobrazí ve všech rubrikách. Pro text zobrazovaný pouze v nezávislých stránkách se píše do sloupce Rubrika slovo ns.
  • Pořadí - pořadí v jakém se bude text zobrazovat na jedné straně.
  • Zobrazovat v detailu článku - přepínač pro zobrazení v detailu článku
  • Zobrazovat v nezáv. stránkách - přepínač pro zobrazení v nezávislých stránkách


Dynamický sloupek

Představuje text, který je dynamicky vkládán do jedné nebo více stránek.

Obsah není uložen na stránce, na které se zobrazuje, ale v samostatném souboru. Tento soubor neobsahuje HTML kód ale JavaScript.
Dynamický sloupek slouží k vytvoření sloupku, který je graficky (barevně) shodný s pravým sloupkem na úvodní straně. Pro vložení takovéto tabulky do textu se použije syntaxe:
<script src="jmeno.js" language="JavaScript"></script>.
Konkrétní HTML kód se získá použitím tlačítka HTML kód.
Při změně obsahu dyn. sloupce není nutné generovat všechny stránky ale pouze dyn. sloupce.

Popis údajů

  • Sloupek - jméno sloupku, ke kterému text patří
  • Nadpis - nadpis textu
  • Pořadí - pořadí v zobrazování textu, který patří k jednomu sloupku
  • Skrýt - text nebude zobrazen
  • Text - vlastní text dynamického sloupku. Může obsahovat HTML kód

Tlačítka

  • Definice sloupku - volba parametrů sloupku

    • Sloupek - jméno sloupku. Bude součástí jména souboru, proto nesmí obsahovat české znaky a mezery.
    • Jméno souboru - jméno souboru tak jak je uloženo
    • Šířka sloupku - šířka v bodech, údaj je nutné zadat. Pro orientaci nejpoužívanější rozlišení je 800x600 tzn., že šířka celé obrazovky je 800 bodů.
    • Skrýt - sloupek se dočasně nebude generovat
    Počet sloupků je u volně šiřitelné verze a základní licence omezen na jeden.
  • HTML kód - zobrazí HTML kód, který je potřeba napsat do místa stránky, kde se bude sloupek zobrazovat
  • EEa - externí editor pro editaci textu sloupku
  • Nový - založí nový text pro sloupek
  • Smazat - smaže text sloupku
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy


Záhlaví - zápatí strany

Hlavička a patička strany mimo úvodní stranu.

Popis údajů

  • Záhlaví - text umístěný v horní části strany. Může obsahovat libovolný HTML kód
  • Zápatí - text umístěný v dolní části strany. Může obsahovat libovolný HTML kód

Popis tlačítek

  • Editovat záhlaví - otevře editor pro editaci záhlaví
  • EE a - otevře externí editor pro editaci záhlaví
  • Editovat zápatí - otevře editor pro editaci zápatí
  • EE b - otevře externí editor pro editaci zápatí
  • OK - zavře okno a uloží změny
  • Odvolat změny - zavře okno bez uložení změn
  • HTML ? - otevření okna se základními HTML tágy


 tabulky 2


Použití programu

Nastavení způsobu použití programu WebGen.cz

Popis údajů

  • Režim programu - zatržením se program nastaví do příslušného módu
  • Zobrazovat okno s nápovědou - zatržením se aktivuje okno, které zobrazuje v průběhu běhu programu rady a tipy pro práci.
Více informací pro nastavení v režimu Weblog Expert


Iniciály

Základní informace o stránkách.

Popis údajů

  • Jméno stránek - titulek, který se objeví v hlavní (horní) liště prohlížeče.
  • Popis stránek - stručný popis tématiky, kterou se stránka zabývá. Je určeno především pro indexovací služby jako je Altavista a má velký význam. Text není viditelný na stránce. Např. "Snímky města Karlovy Vary".
  • Klíčové slova - opět určeno pro indexovací služby, tetokrát se však jedná přímo o klíčová slova.Text není viditelný na stránce. Např. "Karlovy Vary,fotografie,turistika".
  • Název, ulice, obec, DIČ, IČO - údaje pro objednávku *
  • Plátce DPH - nastaví se zda se počíta s DPH (důležité) *
  • E-mail - e-mail, na který se zasílají objednávky(důležité) *
  • Telefon, fax, účet, konst. symbol - údaje pro objednávku *
* - má význam pouze pro e-shop


Sazby - hranice

Popis údajů

  • Sleva
    • Sleva [%] - procento slevy
    • Hranice - hranice po jejíž dosažení se počítá sleva
    • Text slevy - text, který označuje slevu v objednávce
  • Distribuční náklady
    • Hranice pro placení - hranice, do které se platí distribuční náklady
    • Text - text, který označuje náklady s dodávkou objednávky
    • Text 2 - text, který označuje náklady s platbou (např. dobírkovné)
  • DPH
    • Základní sazba [%] - procento základní sazby DPH
    • Snížená sazba [%] - procento snížené sazby DPH
    • Implicitní sazba DPH [%] - hodnota DPH, která se dosadí do položek, kde není uvedena žádná sazba DPH, při přepočtu cen
  • Zaokrouhlení
    • Zaokrouhlení DPH
      • Setníky nahoru
      • Desetníky nahoru
    • Zaokrouhlení objednávky
      • Desetníky nahoru
      • Koruny nahoru
  • Počet položek zboží na stránce - počet současně zobrazených položek na stránce jedné skupiny a podskupiny.


Umístění stránek

Popis údajů

  • Soubory pro web - adresář, do kterého se budou generovat HTML stránky do počítače
  • Malé obrázky - adresář, do kterého je potřeba nakopírovat obrázky pro náhled karet. Stejně nazvaný adresář musí existovat na www serveru.
  • Velké obrázky - adresář, do kterého je potřeba nakopírovat obrázky pro detailní zobrazení karet. Stejně nazvaný adresář musí existovat na www serveru. Platí pro nastavení v režimu e-shop

    Pokud adresář pro velké nebo malé obrázky není v podadresáři kde jsou soubory pro web, musí se cesta stanovit jako relativní vůči adresáři pro web

    např.
    soubory pro web jsou na c:\webgencz\stranky
    malé obrázky jsou na c:\webgencz\male - C:\webgencz\stranky\..\male
    velké obrázky jsou na c:\webgencz\velke - C:\webgencz\stranky\..\velke

  • Jméno hlavního souboru HTML - hlavní HTML soubor, kterým se budou stránky spouštět. Např. index.html, default.html apod. Platí pro nastavení v režimu e-shop
  • Jméno souboru levého rámu - soubor levého rámu (přednastaveno na oddeleni.htm). Doporučujeme měnit pouze v nutném případě. Platí pro nastavení v režimu e-shop

Při kopírování souborů na www server převeďte všechny jména souborů na malé písmena. Nepoužívejte ve jméně souborů mezery, interpukci, lomítka a uvozovky. Vyhnete se problémům se zobrazováním souborů na www.Co funguje ve Windows xx negunguje na www.


Pošta

Nastavení zprávy po odeslání objednávky.

Popis údajů

  • 2. e-mail obchodníka - druhá adresa, na kterou přijde objednávka. První adresa viz. iniciály
  • E-mail mobilního telefonu - adresa na kterou přijde informace o objednávce. Celková cena, odesílatel. (musí podporovat mobilní operátor)
  • Poslat zákazníkovi opis objednávky - e-mail pro zákazníka bude-nebude obsahovat opis objednávky
  • Předmět - předmět e-mailu, který dojde obchodníkovi a odběrateli
  • Text - obsah e-mailu, který dostane pouze odběratel (odezva, že objednávka byla odeslána obchodníkovi)

Odeslání objednávky


Odeslání objednávky

Nastavení textových informací zobrazených po odeslání objednávky.

Úspěšné odeslání objednávky - text, který se zobrazí odběrateli po úspěšném odeslání objednávky
Neúspěšné odeslání objednávky - text, který se zobrazí odběrateli po neúspěšném odeslání objednávky


Vzhled

Konfigurace vzhledu aplikace

Parametry pro nastavení programu v režimu e-shop, e-katalog

Popis údajů

  • Dotazovat se na množství - přepínač zda vyžadovat zadaní počtu při vhození zboží do košíku
  • Upozornění na podlimitní mn. - text, který se zobrazí pokud se objedná méně než je povoleno
  • Po vhození do košíku ukázat košík - přepínač na zobrazení košíku, které následuje okamžitě po vhození zboží do košíku
  • Dotaz- text dotazu zda ukázat košík nebo pokračovat v nákupu
  • Levý rám
    • Odkazy na skupiny a podskupiny zarovnávat - volba zarovnání (nalevo, nastřed, napravo)
    • Uživatelské odkazy zarovnávat - volba zarovnání (nalevo, nastřed, napravo)
  • Šířka rámečku článku - šířka orámování v bodech (0 - bez orámování)
  • Zarovnání obrázku v článku - způsob zarovnání obrázku
    • Left - vlevo
    • Right - vpravo
    • Top - nahoru
    • Texttop - nahoru vůči textu
    • Middle - doprostřed vůči lince textu
    • Bottom - dolů vůči textu
    • Absbottom - dolů
  • Odkaz na celý článek - text odkazu na celý článek
  • Kód před odkazem na předchozí stranu - HTLM kód
  • Odkaz na předchozí stranu - text odkazu
  • Kód za odkazem na předchozí stranu - HTML kód
  • Použít vyhledávání - přepínač pro generování souboru pro vyhledávání v názvu karty
    • Hledaný řetězec - text
    • Tlačítko hledej - text
    • PHP soubor - volba souboru na vyhledávání. S podporou PHP (hledej.php3) nebo JavaScriptu (hledej.htm). Při volbě PHP vyhledávání funguje pouze při umístění stránek na www s podporou PHP jazyka.
    • Nalezené odkazy - text
    • Nic nenalezeno -
    • Počet znaků popisu zboží počet znaků, které budou zahrnuty do souboru pro vyhledávání

Definice rámů, script

Popis údajů

  • Rám
    • Horní rám - parametry horního rámu, změna rozměrů, rolování, odsazení
    • Levý rám -
    • Hlavní rám -
  • Upravit - otevře okno s možnosti editace HTML kódu, který se objeví v prohlížeči, který nepodporuje rámy
  • Script - www adresa scriptu pro zpracování objednávky (odeslání e-mailu zákazníkovi a obchodníkovi). Přednastavená adresa http://www.webgen.cz/php/posliobj.php3


Třídění

Definice zobrazení pořadí jednotlivých karet v oddělení.

Lze nastavit třídění podle 1-4 údajů.


Lokalizace - redakční systém

Nastavení kódové stránky + definice tagu META.

Definuje zda a kde se budou zobrazovat odkazy na články úvodní strany.
Příklad vygenerovaných odkazů:

Obdobně jde nastavit generování scriptu pro jiný server.

Definice šířky orámování tabulky s článkem a definice navigačních odkazů.

Doplňující parametry tabulky s článkem, kód oddělující dva články, zarovnání obrázku, popis odkazů zobrazovaných údajů

Způsob zobrazení datumu.

E-shop E-katalog


Lokalizace - e-shop

Definice znakové sady, textu v horním rámu, textu v informačních oknech

Definice textu tlačítek, navigačních odkazů a dialogových oken

Definice textu na první straně nákupního košíku

Definice textu na druhé straně nákupního košíku

Definice textu na třetí straně nákupního košíku

Definice zobrazení aktuálního datumu v horním rámu

Parametry článků na úvodní straně

Volba formátu zobrazovaného data

E-katalog Redakční systém


Lokalizace - e-katalog

Definice znakové sady, textu v horním rámu, textu v informačních oknech

Definice textu tlačítek, navigačních odkazů a dialogových oken

Parametry článků na úvodní straně

Volba formátu zobrazovaného data

E-shop Redakční systém


Reklamní odkazy

Nastavení scriptu pro zobrazování vybraných karet (karty, které mají jeden z příznaků např. novinka, sleva, výprodej, tip).

Ukázka zobrazených údajů. Obrázek slouží jako odkaz.

Popis údajů

  • Šířka tabulky -
  • Šířka obrázku -
  • Nadpis tabulky -
  • Zdrojový kód - zdrojový kód je možné libovolně umístit do stránek


Způsob dopravy

Nastavení způsobu dopravy pro doručení objednávky.

Sloupce souboru
  • Název - Popis způsobu dopravy
  • Cena - cena bez DPH
  • DPH - procento DPH


Způsob úhrady

Nastavení způsobu úhrady pro zaplacení objednávky.

Sloupce souboru
  • Název - Způsobu úhrady
  • Cena - cena bez DPH
  • DPH - procento DPH
  • Akce - umožní přesměrování na platební bránu eBanky.
Pro import objednávek do programu POHODA jsou povolené názvy:
  • hotově
  • inkasem
  • dobírkou
  • plat.kartou
  • příkazem
  • složenkou
  • šekem
  • zálohou
  • zápočtem


I LIKE Q

Nastavení parametrů platební brány.

Údaje se vyplní podle údajů obchodníka. Podmínkou je zřízení účtu na I LIKE Q
Způsob úhrady


eBanka

Nastavení parametrů platební brány.

Údaje se vyplní podle údajů obchodníka. Podmínkou je zřízení účtu v eBance
Způsob úhrady NetBanka


Monetka

Nastavení parametrů platební brány.

Údaje se vyplní podle údajů obchodníka. Podmínkou je zřízení účtu na Monetka.cz
Způsob úhrady I LIKE Q eBanka


Barvy

Nastavení barevné kombinace stránek.

Záložka Rám
Rám je horní a levá část obrazovky dle nastavení.
Nastavitelné parametry:
  • Barva textu - kód barvy
  • Nadpis oddělení - kód barvy
  • Podklad oddělení - kód barvy
  • Odkaz - kód barvy
  • Aktuální odkaz - kód barvy
  • Navštívený odkaz - kód barvy
  • Podklad rámu - kód barvy
  • Obrázek horní - soubor
  • Obrázek boční - soubor
Pravým tlačítkem myši v editačním poli se zobrazí paleta barev, respektive okno pro nalistování souboru s obrázkem. Do kódu barvy lze zapsat přímo název barvy (white, red ..)

Záložka okno
Okno je část obrazovky mimo rám.
Nastavitelné parametry:
  • Barva textu - kód barvy
  • Odkaz - kód barvy
  • Aktuální odkaz - kód barvy
  • Navštívený odkaz - kód barvy
  • Barva podkladu - kód barvy
  • Obrázek - soubor

Záložka články
Nastavitelné parametry:
  • Barva nadpisu - kód barvy
  • Podklad nadpisu - kód barvy
  • Podklad článku - kód barvy

Tlačítka

Uložit - uloží profil pod aktuálním názvem
Uložit jako - uloží profil pod novým názvem
Načíst - načte profil z databáze profilů

Spolu s profilem určuje vzhled (taky se nahrává a ukládá) styl CSS.


Rozmístění přehled

Definice rozmístění údajů v okně přehledu

Popis údajů

  • Hlavička - HTML kód uvozující skupinu údajů k jedné položce katalogu
  • Obrázek -
    • Pořadí - pořadí (0-11) zobrazení údaje obrázek, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj obrázek
    • Kód za - HTML kód vložený za údaj obrázek
    • Zarovnání - způsob zarovnání obrázku
      • Left - vlevo
      • Right - vpravo
      • Top - nahoru
      • Texttop - nahoru vůči textu
      • Middle - doprostřed vůči lince textu
      • Bottom - dolů vůči textu
      • Absbottom - dolů
  • Novinka -
    • Pořadí - pořadí (0-11) zobrazení údaje novinka, 0 - údaj se nezobrazí
    • Kód - kód, který se zobrazí u karty označené jako novinka
  • Kód -
    • Pořadí - pořadí (0-11) zobrazení údaje kód, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj kód
    • Kód za - HTML kód vložený za údaj kód
  • Název - nastavení viz. kód
  • Cena bez DPH - nastavení viz. kód
  • Koncová cena - nastavení viz. kód
  • Původní cena - nastavení viz. kód
  • DPH - nastavení viz. kód
  • Popis - nastavení viz. kód
  • Výrobce - nastavení viz. kód
  • Koupit - nastavení viz. kód
  • Měna - označení měny. Přidává se za údaj s cenou.
  • Detail -
    • Kód před - HTML kód vložený před odkaz detail
    • Text odkazu - text odkazu na zobrazení detailní informace o kartě
    • Kód za - HTML kód vložený za odkaz detail
  • Patička - HTML kód ukončující skupinu údajů k jedné položce katalogu
  • Oddělovač - kód oddělující následující položku katalogu (např. čára <HR>)

Rozmístění detail


Rozmístění detail

Definice rozmístění údajů v okně detailu

Popis údajů

  • Hlavička - HTML kód uvozující skupinu údajů k jedné položce katalogu
  • Obrázek -
    • Pořadí - pořadí (0-12) zobrazení údaje obrázek, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj obrázek
    • Kód za - HTML kód vložený za údaj obrázek
    • Zarovnání - způsob zarovnání obrázku
      • Left - vlevo
      • Right - vpravo
      • Top - nahoru
      • Texttop - nahoru vůči textu
      • Middle - doprostřed vůči lince textu
      • Bottom - dolů vůči textu
      • Absbottom - dolů
  • Novinka -
    • Pořadí - pořadí (0-12) zobrazení údaje novinka, 0 - údaj se nezobrazí
    • Kód - kód, který se zobrazí u karty označené jako novinka
  • Kód -
    • Pořadí - pořadí (0-12) zobrazení údaje kód, 0 - údaj se nezobrazí
    • Kód před - HTML kód vložený před údaj kód
    • Kód za - HTML kód vložený za údaj kód
  • Název - nastavení viz. kód
  • Cena bez DPH - nastavení viz. kód
  • Koncová cena - nastavení viz. kód
  • Původní cena - nastavení viz. kód
  • DPH - nastavení viz. kód
  • Popis - nastavení viz. kód
  • Detail popis - nastavení viz. kód
  • Výrobce - nastavení viz. kód
  • Koupit - nastavení viz. kód
  • Měna - označení měny. Přidává se za údaj s cenou.
  • Zpět -
    • Kód před - HTML kód vložený před odkaz zpět
    • Text odkazu - text odkazu na návrat na předchozí stranu
    • Kód za - HTML kód vložený za odkaz zpět
  • Patička - HTML kód ukončující skupinu údajů k jedné položce katalogu

Rozmístění přehled


Externí editor

Umožňuje využít externí editor pro editaci HTML kódu.

Jako externí editor se dosadí oblíbený HTML nebo jiný editor např. notepad.exe.
Volání externího editoru z programu se provádí tlačítkem [image] v editačním okně. Po ukončení editace v externím editoru se vyvolá dialogové okno na dotaz zda upravený text načíst.


Styl CSS

Definice kaskádových stylů - vzhledu písma, tabulek.

Předdefinovaný styl:
.n_clanek - nadpis článku
.clanek - obsah článku
.cldatum - datum vytvoření článku
.clautor - autor článku
.clrubrika - rubrika, do které patří článek
.clnadrubrika - nadřazená rubrika, do které patří článek
.levy_sl_v - vrchní text levého sloupce (rámu)
.levy_sl_s - spodní text levého sloupce (rámu)
.jmeno - jméno obchodu, nadpis v horním rámu
.odkaz - odkazy v horním rámu
.n_sloupek - nadpis článku ve sloupku
.sloupek - obsah sloupku
.n_oddeleni - nadpis oddělení
.n_skupina - nadpis skupina
.skupina - jméno skupiny
.skupina_roz - skupina rozbalená
.skupina_ner - skupina nerozbalená
.skupina_root - návrat na úvodní skupiny
.rubrikanadpis - nadpis pro rubriky
.rubrika - jednotlivé rubriky
.rubrika_akt - aktuálně zobrazená rubrika
input.tl_koupit - tlačítko koupit
input.tl_zpet - tlačítko zpět
input.tl_prep - tlačítko přepočítat
input.tl_dalsi - tlačítko další
input.tl_tisk - tlačítko tisk
input.vstup - vstupní jednořádkové pole
textarea.vstup - vstupní víceřádkové pole
input.cena - pole s celkovou cenou

Detail zboží
.s_d_kod - kód
.s_d_nove - nové
.s_d_cenab - cena bez DPH
.s_d_cena - prodejní cena
.s_d_dph - DPH
.s_d_starac - původní cena
.s_d_nazev - název
.s_d_popis - popis
.s_d_dpopis - detailní popis
.s_d_výrobce - výrobce
.s_d_zpet - zpět na přehled

Přehled zboží
.s_nove - nové
.s_kod - kód
.s_cenab - cena bez DPH
.s_cena - prodejní cena
.s_starac - původní cena
.s_dph - DPH
.s_nazev - název
.s_popis - popis
.s_výrobce - výrobce
.s_info - na detail

Tabulky
.TAB1 - tabulka na odkazy do oddělení z levého rámu
.TAB2 TD.R1 - články hlavička
.TAB2 TD.R2 - články tělo
.TAB2 TD.R3 - články patička
.TAB3 TD.R1 - tip (e-shop, e-katalog) hlavička
.TAB3 TD.R2 - tip (e-shop, e-katalog) tělo
.TAB3 TD.R3 - tip (e-shop, e-katalog) patička
.TAB4 TD.R1 - sloupek hlavička
.TAB4 TD.R2 - sloupek tělo
.TAB4 TD.R3 - sloupek patička
.TAB5 TH - nákupní košík nadpis
.TAB5 TR.R1 - nákupní košík položky liché
.TAB5 TR.R0 - nákupní košík položky sudé
.TAB6 TH - nákupní košík nadpis DPH
.TAB6 TD - nákupní košík položky DPH
.TAB7 TH - nák. košík vstupní formulář odběratel nadpis
.TAB7 TD - nák. košík vstupní formulář odběratel
.TAB8 - objednávka hlavička
.TAB10 - tabulka pro odkazy z levého rámu (e-shop, e-katalog)
.TAB12 - odkazy horní rám (e-shop, e-katalog)
.TAB13 - odkazy rubriky levý sloupec (redakční systém)

Navigace v záhlaví a zápatí strany oddělení
A.s_next - navigace v oddělení
A.s_p - odkazy na strany
.s_p1 - nadpis skupiny - strana
.s_p2 - strana 1 z X
TD.s_p - podklad strana z X

Detailnější popis jak na CSS najdete na internetu např. na http://www.jakpsatweb.cz
Barvy


Generuj

Spustí generování HTML stránek. Klávesa CTRL+F9 (viz. Horké klávesy)
Soubory se ukládají do adresáře nastaveného v parametrech.


Generuj dynamické sloupky

Spustí generování dynamických sloupků. Klávesa CTRL+F8 (Horké klávesy)
Soubory se ukládají do adresáře nastaveného v parametrech.


Ukaž

Zobrazí vygenerované HTML stránky. Klávesa F9 (horké klávesy)

Pokud je prohlížeč stránek již spuštěný a spustí se opětovné generování, je potřeba v prohlížeči aktualizovat obsah pomocí tlačítka obnovení (reload) stránek (klávesa F5).

Generuj Generuj dynamické sloupky


Změny HTML

Funkce provádí porovnání posledně vygenerovaných stránek (uloženy v kořenovém adresáři) a stránek, které se vytvořily při posledním použití funkce /Změny HTML/ (podadresář aktualni)

Rozdíl mezi obsahem těchto dvou adresářů je uložen do adresáře zmeny. Porovnává se obsah jednotlivých souborů.
Příklad:
Doposud se funkce /Změny HTML/ nepoužila.
1 - Spustíme generování stránek.
2 -Spustíme /Změny HTML/ a dáme si zobrazit změněné stránky. Měl by se zobrazit seznam všech souborů. Tyto soubory jsou uloženy v adresáři /zmeny/. Porovnal se podadresář /aktualni/, který byl prázdný, a kořenový adresář, který obsahuje všechny soubory. Na konci této operace se obsah kořenového adresáře přesune do podadresáře /aktualni/, který simuluje stav se soubory na www.
3 -Nyní je program připravem zaznamenat změny, které se provedou od této chvíle (spuštění funkce /Změny HTML/ nikoliv generování).
4 - V této chvíli můžeme provést zásah do obsahu databáze (doplnit nový článek, zboží apod.).
5 - Provedeme vygenerování stránek a zjistíme ještě chybu.
6 - Chybu opravíme a opět vygenerujeme stránky. (provádíme do té doby, než je vše OK)
7 -Spustíme funkci /Změny HTML/ a v adresáři /zmeny/ jsou modifikované soubory. Nejenom nové soubory, ale i staré, které mají vazbu na provedené změny.

Pozor spouští se vždy až po provedení všech změn, jinak se zobrazí nepřesné informace.


Okna

Volba rozmístění již otevřených oken na obrazovce. Mozaika nebo kaskáda.


Nápověda

Zobrazení této nápovědy.


Registrace

Zadání registračního čísla pro rozšíření free verze programu na plnou verzi. Více informací o získání registrace získáte na stránce www.webgen.cz


Informace

Zobrazení informací o verzi programu.


Asociace

Tabulka speciálních znaků, které je potřeba nahradit v textu HTML stránky, aby došlo ke správnému zobrazení.

Zobrazený znak | Zapsaný znak
< | &lt;
> | &gt;
& | &amp;
" | &guot;
§ | &sect;
© | &copy;
® | &reg;
™ | &#153;
mezera | &nbsp;


Přenos souborů na web pomocí FTP klienta

FTP klient

V záložce Parametry je potřeba nejdříve vyplnit údaje
  • Program - umístění programu ftp_wg.exe. Pro lze samostatně stáhnou z webu http://www.webgen.cz/download
  • Jméno ftp - jméno ftp serveru
  • Uživatel - jméno uživatele
  • Heslo - heslo pro přístup na ftp
  • Adresář - pokud jsou stránky umístěné v adresáři na ftp, tak jeho název
  • Převést jména souborů na malá písmena - zatrhnout, jinak může nastat problém
ftp2.png, 7 kB

Záložka Přenos

ftp1.png, 7 kB
  • Kopírovat soubory
    • Jenom nové - kopírují se jenom nové (neexistující na ftp) soubory. Doporučeno
    • Všechny - kopírují se všechny soubory. Nevhodné nastavení pro kopírování obrázků, protože se znovu kopírují i soubory, které jsou již na ftp
  • Vygenerované stránky - obsah hlavního adresáře
  • Vygenerované stránky - změny - obsah adresáře změny, který se naplní soubory po spuštění operace HTML stránky/Změny HTML
  • Náhledové obrázky - obsah adresáře s náhledovými obrázky
  • Detailní obrázky - obsah adresáře s detailními obrázky
  • Uživatelský adresář 1 - uživatelem zvolený adresář
  • Uživatelský adresář 2 - uživatelem zvolený adresář
  • Uživatelský adresář 3 - uživatelem zvolený adresář


Hot Key

Horké klávesy

  • CTRL+K - okno s kartami zboží (Karty)
  • CTRL+1 - 1. vlastní pohled na karty
  • CTRL+2 - 2. vlastní pohled na karty
  • CTRL+3 - 3. vlastní pohled na karty
  • CTRL+4 - 4. vlastní pohled na karty
  • CTRL+5 - 5. vlastní pohled na karty
  • CTRL+6 - 6. vlastní pohled na karty
  • CTRL+7 - 7. vlastní pohled na karty
  • CTRL+L - okno s články (Články)
  • CTRL+S - okno sloupku (Sloupek)
  • CTRL+F9 - generování stránek (Generuj)
  • CTRL+F8 - generování dynamických sloupků (Generuj dynamické sloupky)
  • F8 - zobrazí změněné soubory od poslední použití této funkce(Změny HTML)
  • F9 - zobrazí HTML stránky ve www prohlížeči (Ukaž)
  • ALT+F4 - konec programu WebGen.cz (Konec programu)


Pravidla pro jména souboru

Zásady pro vytváření jména souboru
  • používat pouze základní znaky a čísla
  • nepoužívat české znaky
  • nepoužívat speciální znaky (lomítko, středník ... )
  • používat pouze malá písmena
Použitím uvedených zásad se zmenší problémy při přesunu stránek z lokalního počítače na www, kde platí jiné pravidla pro soubory.


Klíčová slova

Klíčová slova v režimu Weblog

Šablony pro stránky mohou obsahovat následující klíčová slova, která se nahrazují konkrétními hodnotami. Neznámá klíčová slova zůstanou beze změny.

Obecná klíčová slova

  • <!-- %TITLE% --> titulek stránky
  • <!-- %BUILD_DATE_TIME% --> datum a čas vygenerovaného souboru RSS
  • <!-- %BUILD% --> verze programu WebGen.cz
  • <!-- %HOME_PAGE% --> - odkaz na úvodní stranu
  • <!-- %IS_ACTIVE()% --> pro aktivní rubriku zapíše parametr
  • <!-- %NOT_ACTIVE()% --> pro neaktivní rubriku zapíše parametr
  • <!-- %FILE_NOT_ACTIVE% --> pro neaktivní rubriku zapíše jméno souboru rubriky
  • <!-- %NAME_F_CHAR_NOT_ACTIVE% --> 1. znak jména rubriky jetliže není aktivní
  • <!-- %NAME_F_CHAR% --> 1. znak jména rubriky
  • <!-- %NAME_N_CHARS% --> jméno rubriky od druhého znaku
  • <!-- %ACTUAL_SUBCATEGORY_NAME% --> jméno aktuální rubriky
  • <!-- %ACTUAL_CATEGORY_NAME% --> jmeno aktuální nadřízené rubriky
  • <!-- %ARCHIVE% --> seznam odkazů do archivu
  • <!-- %CATEGORY_LIST% --> seznam odkazů rubrik a nadřízených rubrik, zobrazí současně všechny rubriky
  • <!-- %CATEGORY_LIST_O% --> seznam odkazů rubrik a nadřízených rubrik, zobrazí pouze aktuální podřízené rubriky
  • <!-- %CATEGORY_LIST_LI% --> seznam odkazů rubrik a nadřízených rubrik pomocí tágu <UL>, zobrazí pouze aktuální podřízené rubriky. Je rozlišena aktuálně vybraná rubrika. id=nav1, id=nav2, id=aktivni
  • <!-- %CATEGORY_LIST_LI_2% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - id nav1,2
  • <!-- %CATEGORY_LIST_LI_3% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - volné UL
  • <!-- %CATEGORY_LIST_LI_4% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - id nav1,2 přechod z nadřízené na první základní rubriku,
  • <!-- %CATEGORY_LIST_LI_5% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - volné UL přechod z nadřízené na první základní rubriku
  • <!-- %CATEGORY_LIST_LI_6% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - id nav1,2 {pouze nadřízené, nebo základní bez nadřízené}
  • <!-- %CATEGORY_LIST_LI_7% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - volné UL {pouze nadřízené, nebo základní bez nadřízené}
  • <!-- %CATEGORY_LIST_LI_8% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - id nav1,2 přechod z nadřízené na první základní rubriku {pouze nadřízené, nebo základní bez nadřízené},
  • <!-- %CATEGORY_LIST_LI_9% --> - seznam odkazů, kombinace nadřízené a základní rubriky <li> - volné UL přechod z nadřízené na první základní rubriku {pouze nadřízené, nebo základní bez nadřízené}
  • <!-- %SUBCATEGORY_LIST_LI% --> - seznam odkazů, podřízená rubrika <li> - id nav1,2,
  • <!-- %SUBCATEGORY_LIST_LI_2% --> - seznam odkazů, podřízená rubrika <li> - volné UL
  • <!-- %TEXT_1% --> dlouhý text 1 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %TEXT_2% --> dlouhý text 2 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %TEXT_3% --> dlouhý text 3 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %TEXT_4% --> dlouhý text 4 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %SUBCATEGORY_TEXT_1% --> text(HTML kód) patřící konkrétní kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %SUBCATEGORY_TEXT_2% --> text(HTML kód) patřící konkrétní kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %SUBCATEGORY_TEXT_3% --> text(HTML kód) patřící konkrétní kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %SUBCATEGORY_TEXT_4% --> text(HTML kód) patřící konkrétní kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %CATEGORY_TEXT_1% --> text(HTML kód) patřící konkrétní nadřízené kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %CATEGORY_TEXT_2% --> text(HTML kód) patřící konkrétní nadřízené kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %CATEGORY_TEXT_3% --> text(HTML kód) patřící konkrétní nadřízené kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %CATEGORY_TEXT_4% --> text(HTML kód) patřící konkrétní nadřízené kategorii. Zobrazí se na příslušné stránce rubriky/detailu článku
  • <!-- %ACTUAL_CATEGORY()% --> aktuální nadřízená rubrika,
  • <!-- %ACTUAL_CATEGORY34()% --> aktuální nadřízená rubrika, otevře první základní rubriku této nadřízené rubriky,
  • <!-- %ACTUAL_SUBCATEGORY()% --> aktuální rubrika,
  • <!-- %ACTUAL_PAGE()% --> aktuální detail článku, sloupku,

Klíčová slova článku

Následující klíčová slova lze použít pouze v bloku článku, jinde nemají žádný význam:
<!-- %CONTENT_START% -->, <!-- %CONTENT_END% --> - začátek/konec článku. Tento blok se opakuje pro každý článek na stránce a klíčová slova uvnitř se nahrazují údaji z konkrétního článku
<!-- %CONTENT_START_0% --> - sudé články
<!-- %CONTENT_START_1% --> - liché články
<!-- %PREV_CONTENT_START(kategorie)% --> - články patřící do určité kategorie (nemusí být definována)
<!-- %CONTENT_START_CLASSED% --> - pouze zatříděné články do existující kategorie
<!-- %CONTENT_START_CATEGORY% --> články patřící pouze do nadřízené kategorie,
<!-- %CONTENT_START_TO()% --> začátek bloku články do čísla (parametr)
<!-- %CONTENT_START_FROM()% --> začátek bloku články od čísla (parametr)
  • <!-- %DATE% --> datum článku
  • <!-- %PERMALINK% --> trvalý odkaz do archívu
  • <!-- %FULL_PERMALINK% --> trvalý odkaz do archívu včetně adresy
  • <!-- %FULL_PERMALINK_DETAIL% --> trvalý odkaz na detail včetně adresy
  • <!-- %ANCHOR% --> unikátní ID článku (součást trvalého odkazu).
    Pro korektní fungování archivu by šablona měla v bloku příspěvku obsahovat kód
    <a name="<!-- %ANCHOR% -->"></a> - na tyto pojmenované odkazy jsou směřovány trvalé odkazy do archivu.
  • <!-- %CATEGORY% --> rubrika článku
  • <!-- %HREF_CATEGORY% --> odkaz do rubriky
  • <!-- %HREF_ROOT_CATEGORY% --> odkaz do nadřízené rubriky
  • <!-- %ROOT_CATEGORY% --> nadřízená rubrika článku
  • <!-- %TITLE% --> nadpis článku
  • <!-- %IMAGE% --> obrázek článku
  • <!-- %IMAGE_D% --> - obrázek detailu článku,
  • <!-- %IMAGE_P% --> - obrázek přehledu článku,
  • <!-- %IS_DET()% --> zapíše obsah parametru pokud existuje detail článku
  • <!-- %HREF_DET_CONTENT% --> soubor s detailem článku pokud existuje, jinak zapíše znak #
  • <!-- %IS_HREF_DET_CONTENT% --> soubor s detailem článku pokud existuje, jinak nezapíše nic
  • <!-- %IS_IMAGE()% --> pokud existuje v přehledu článku náhledový obrázek/v detailu náhledový nebo detailní obrázek, tak zapíše parametr
  • <!-- %IS_IMAGE_P()% --> pokud existuje náhledový obrázek článku, tak zapíše parametr
  • <!-- %IS_IMAGE_D()% --> pokud existuje detailní obrázek článku, tak zapíše parametr
  • <!-- %CONTENT% --> obsah článku
  • <!-- %PREV_CONTENT(X)% --> obsah článku, prvních X znaků
  • <!-- %DET_CONTENT% --> pouze detailní obsah článku
  • <!-- %XML_CONTENT% --> obsah článku pro RSS soubor (bez HTML tágů)
  • <!-- %AUTHOR_MAIL% --> e-mail autora článku
  • <!-- %AUTHOR% --> jméno autora článku
  • <!-- %IS_0()% --> zobrazí parametr pro sudé články
  • <!-- %NOT_0()% --> zobrazí parametr pro liché články
  • <!-- %STRING_1% --> sloupec STRING_1 článku
  • <!-- %STRING_2% --> sloupec STRING_2 článku
  • <!-- %IS_STRING_1()% --> jestliže je vyplněn obsah sloupce STRING_1 článku, zobrazí se obsah parametru
  • <!-- %IS_STRING_2()% --> jestliže je vyplněn obsah sloupce STRING_2 článku, zobrazí se obsah parametru

Nezávislé stránky

<!-- %IND_PAGE_START% --> <!-- %IND_PAGE_END% --> začátek/konec nezávislé stránky
  • <!-- %TITLE% --> titulek nezávislé stránky
  • <!-- %CONTENT% --> obsah nezávislé stránky

Sloupek

<!-- %COLUMN_START% --> <!-- %COLUMN_END% --> začátek/konec sloupku
<!-- %COLUMN_START_TO()% --> začátek bloku sloupek do čísla (parametr)
<!-- %COLUMN_START_FROM()% --> začátek bloku sloupek od čísla (parametr)
  • <!-- %TITLE% --> titulek sloupku
  • <!-- %CONTENT% --> obsah sloupku

Seznam rubrik

<!-- %CATEGORY_LIST_START% --> <!-- %CATEGORY_LIST_END% --> začátek/konec seznamu rubrik
<!-- %CATEGORY_LIST_START_TO()% --> začátek bloku kategorie do čísla (parametr)
<!-- %CATEGORY_LIST_START_FROM()% --> začátek bloku kategorie od čísla (parametr)
<!-- %SUBCATEGORY_LIST_START% --> začátek bloku podřízené kategorie
<!-- %SUBCATEGORY_LIST_END% --> konec bloku podřízené kategorie
  • <!-- %FILE% --> jméno souboru rubriky
  • <!-- %NAME% --> název rubriky

Weblog


Klíčová slova v režimu Expert

Šablony pro stránky mohou obsahovat následující klíčová slova, která se nahrazují konkrétními hodnotami. Neznámé klíčové slova zůstanou beze změny.

Obecná klíčová slova

  • <!-- %TITLE% --> titulek stránky
  • <!-- %BUILD% --> verze programu WebGen.cz
  • <!-- %SC_E_SHOP% --> scripty pro práci e-shopu (není vidět)
  • <!-- %SC_E_CATALOG% --> scripty pro práci e-katalogu (není vidět)
  • <!-- %SEARCH_DATA% --> datové údaje pro soubor hledání v JavaScriptu
  • <!-- %SEARCH_DATA_PHP% --> datové údaje pro soubor hledání v PHP
  • <!-- %LOG_DATA_PHP% --> datové údaje pro soubor přihlášení v PHP
  • <!-- %DATA_GOODS_SEARCH% --> dosazení umístění pokud se použije NOP bez detailu
  • <!-- %GROUP_LIST% --> seznam odkazů hlavních skupin zboží (oddělovač nový řádek)
  • <!-- %L_GROUP_LIST% --> seznam odkazů podřízených skupin zboží (oddělovač nový řádek)
  • <!-- %GROUP_LIST_HERE% --> seznam odkazů hlavních skupin zboží (oddělovač nový řádek), zobrazení v aktuálním okně
  • <!-- %L_GROUP_LIST_HERE% --> seznam odkazů podřízených skupin zboží (oddělovač nový řádek), zobrazení v aktuálním okně
  • <!-- %GROUP_LIST_HERE_UL% --> seznam odkazů hlavních skupin zboží (formát <UL> <LI> ), zobrazení v aktuálním okně
  • <!-- %L_GROUP_LIST_HERE_UL()% --> seznam odkazů podřízených skupin zboží (formát <UL> <LI>), zobrazení v aktuálním okně, v parametru je znak pro odsazeni podřízené skupiny
  • <!-- %GROUP_LIST3% --> seznam odkazů hlavních skupin zboží (oddělovač mezera)
  • <!-- %GROUP_LIST_START% --> <!-- %GROUP_LIST_END% --> začátek/konec bloku pro vlastní definici seznamu odkazů hlavních skupin zboží
  • <!-- %FILE% --> soubor skupiny
  • <!-- %NAME% --> jméno skupiny
  • <!-- %HEAD_PAGE_GROUP% --> hlavička skupiny oddělení, které se dale člení
  • <!-- %FOOT_PAGE_GROUP% --> patička skupiny oddělení, které se dale člení
  • <!-- %LINKS_LEFT_LIST% --> seznam odkazů z levého rámu (jednoduché zobrazení)
  • <!-- %LINKS_LEFT_LIST_START% --> <!-- %LINKS_LEFT_LIST_END% --> začátek/konec seznamu odkazů z levého rámu
    • <!-- %NAME% --> text odkazu
    • <!-- %TITLE% --> alternativní text
    • <!-- %IMAGE% --> soubor s obrázkem
    • <!-- %FILE% --> soubor, na který ukazuje odkaz
  • <!-- %LINKS_TOP_LIST% --> seznam odkazů z horního rámu (jednoduché zobrazení)
  • <!-- %LINKS_TOP_LIST_START% --> <!-- %LINKS_TOP_LIST_END% --> začátek/konec seznamu odkazů z horního rámu
    • <!-- %NAME% --> text odkazu
    • <!-- %TITLE% --> alternativní text
    • <!-- %IMAGE% --> soubor s obrázkem
    • <!-- %FILE% --> soubor, na který ukazuje odkaz
  • <!-- %FORM_PDATA% --> proměnné pro práci e-shopu (není vidět)
  • <!-- %FORM_PDATA_NOP% --> proměnné pro práci e-shopu - koš 2 strana pro NOP
  • <!-- %TRANSPORT% --> způsob dopravy - košík druhá strana
  • <!-- %TRANSPORT_NOP% --> způsob dopravy - košík druhá strana pro NOP
  • <!-- %PAYMENT% --> způsob úhrady - košík druhá strana
  • <!-- %PAYMENT_NOP% --> způsob úhrady - košík druhá strana pro NOP
  • <!-- %XML_POHODA% --> podpora pro vytvoření objednávky s přílohou HTML+XML pro import do programu POHODA - košík druhá strana
  • <!-- %XML_MONEYS3% --> vytvoří XML přílohu pro načtení objednávky do programu Money S3. Vkládá se do šablony košíku 2. strana
  • <!-- %TEXT_1% --> dlouhý text 1 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %TEXT_2% --> dlouhý text 2 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %TEXT_3% --> dlouhý text 3 (umožňuje vložit text, který má delší řádky než 255 znaků)
  • <!-- %TEXT_4% --> dlouhý text 4 (umožňuje vložit text, který má delší řádky než 255 znaků)

Klíčová slova článku

Následující klíčová slova lze použít pouze v bloku článku, jinde nemají žádný význam:
<!-- %CONTENT_START% -->, <!-- %CONTENT_END% --> - začátek/konec článku. Tento blok se opakuje pro každý článek na stránce a klíčová slova uvnitř se nahrazují údaji z konkrétního článku
  • <!-- %DATE% --> datum článku
  • <!-- %TITLE% --> nadpis článku
  • <!-- %IMAGE% --> obrázek článku
  • <!-- %CONTENT% --> obsah článku
  • <!-- %DET_CONTENT% --> pouze detailní obsah článku
  • <!-- %AUTHOR_MAIL% --> e-mail autora článku
  • <!-- %AUTHOR% --> jméno autora článku
  • <!-- %STRING_1% --> sloupec STRING_1 článku
  • <!-- %STRING_2% --> sloupec STRING_2 článku
  • <!-- %IS_STRING_1()% --> jestliže je vyplněn obsah sloupce STRING_1 článku, zobrazí se obsah parametru
  • <!-- %IS_STRING_2()% --> jestliže je vyplněn obsah sloupce STRING_2 článku, zobrazí se obsah parametru

Nezávislé stránky

<!-- %IND_PAGE_START% --> <!-- %IND_PAGE_END% --> začátek/konec nezávislé stránky
  • <!-- %TITLE% --> titulek nezávislé stránky
  • <!-- %CONTENT% --> obsah nezávislé stránky

Stránky - horní rám odkazy

<!-- %LINKS_TOP_START% --> <!-- %LINKS_TOP_END% --> začátek/konec stránky - horní rám odkazy
  • <!-- %CONTENT% --> obsah stránky

Stránky - levý rám odkazy

<!-- %LINKS_LEFT_START% --> <!-- %LINKS_LEFT_END% --> začátek/konec stránky - levý rám odkazy
  • <!-- %CONTENT% --> obsah stránky

Sloupek

<!-- %COLUMN_START_ALL% --> <!-- %COLUMN_END% --> začátek/konec sloupku - vždy všechny údaje
<!-- %COLUMN_START% --> <!-- %COLUMN_END% --> začátek/konec sloupku
  • <!-- %TITLE% --> titulek sloupku
  • <!-- %CONTENT% --> obsah sloupku
  • <!-- %CONTENT_P% --> pouze anotace sloupku

Stánky s přehledem karet

  • <!-- %SC_P_GOODS% --> scripty pro práci e-shopu (není vidět)
  • <!-- %SC_P_GOODS_MIN% --> minimalní varianta scriptu (pro nastavení "samostatný detail")
  • <!-- %DATA_GOODS% --> proměnné s obsahem zboží (není vidět)
  • <!-- %DATA_GOODS_MIN% --> minimalní varianta pro nastavení "samostatný detail")
  • <!-- %DET_IMAGE_FIRST% --> první detailní obrázek na stránce přehledu
  • <!-- %DETAIL_FIRST% --> první detailní soubor karty na stránce přehledu (pro nastavení "samostatný detail")
  • <!-- %HEAD_PAGE% --> hlavička stránky pro konkrétní oddělení
  • <!-- %COLUMN_PAGE% --> "pravý sloupec" stránky pro konkrétní oddělení
  • <!-- %GROUP_NAME% --> jméno aktuálního oddělení
  • <!-- %ACTUAL_PAGE% --> číslo aktuálně zobrazené stránky pro konkrétní oddělení
  • <!-- %TOTAL_PAGES% --> celkový počet stránek pro konkrétní oddělení
  • <!-- %PAGES_GOODS% --> odkazy na všechny stránky konkrétního oddělení
  • <!-- %PAGES_GOODS()% --> seznam stránek oddělení s parametrem odělovače
  • <!-- %CLASSED_IN()% --> stránka zatříděna ve skupinách - odkazy, parametr oddělovač
  • <!-- %SUBGROUPS()% --> oddělení se dále dělí na skupiny - odkazy, parametr oddělovač
  • <!-- %COUNT_ITEMS% --> počet položek v oddělení (na stránce přehledu)
  • <!-- %PREVIOUS_PAGE% --> předchozí stránka v rámci oddělení
  • <!-- %NEXT_PAGE% --> následující stránka v rámci oddělení
  • <!-- %FOOT_PAGE% --> patička stránky pro konkrétní oddělení

Údaje o kartě (pro stránky s přehledem)

<!-- %VIEW_GOODS_START% --> <!-- %VIEW_GOODS_END% --> začátek/konec údajů o kartě
<!-- %VIEW_GOODS_START()% --> <!-- %VIEW_GOODS_END% --> začátek/konec údajů o kartě. V parametru je volba třídění
např.
(ORDER BY kod DESC) - dle položky sestupně
(ORDER BY NAZEV) - dle názvu
  • <!-- %CODE% --> kód karty
  • <!-- %ID% --> interní číslo zboží na dané stránce (přiděluje program)
  • <!-- %IMAGE% --> soubor s obrázkem
  • <!-- %TITLE% --> název položky
  • <!-- %PRODUCER% --> výrobce
  • <!-- %COMBO_PRODUCER% --> vygeneruje kód pro zobrazení obsahu comba s údajem výrobce <option value="XXX">XXX</option>
  • <!-- %MJ% --> množstevní jednotka
  • <!-- %VAT% --> procento DPH
  • <!-- %PRICE_WITHOUT% --> cena bez DPH
  • <!-- %PRICE% --> cena s DPH
  • <!-- %PRICE1_STRING% --> cena 1 s DPH zobrazená jako textový údaj (12,-)
  • <!-- %PRICE1_WITHOUT_STRING% --> cena 1 bez DPH zobrazená jako textový údaj (12,-)
  • <!-- %OLD_PRICE_STRING% --> původní cena zobrazená jako textový údaj (12,-)
  • <!-- %DESCRIPTION% --> popis
  • <!-- %DETAIL_FILE% --> soubor s detailem karty (pro nastavení "samostatný detail")
  • <!-- %DETAIL_FILE_IS_TYPE_X% --> - zapíše detail souboru pokud je nějaké provedení záložky x-y
  • <!-- %DETAIL_TRUE% --> je detailní popis (A/N)
  • <!-- %PAR_STR_0% --> text 255 znaků
  • <!-- %COMBO_PARSTR0% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR0 <option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR1% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR1<option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR2% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR2 <option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR3% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR3 <option value="XXX">XXX</option>, ukázka
  • <!-- %COMBO_PARSTR4% --> vygeneruje kód pro zobrazení obsahu comba s údajem PARSTR4 <option value="XXX">XXX</option>, ukázka
  • <!-- %PAR_STR_1% --> text 50 znaků
  • <!-- %PAR_STR_2% --> text 50 znaků
  • <!-- %PAR_STR_2% --> text 50 znaků
  • <!-- %PAR_STR_4% --> text 50 znaků
  • <!-- %PAR_STR_5% --> text 50 znaků
  • <!-- %PAR_INT_1% --> celé číslo
  • <!-- %PAR_INT_2% --> celé číslo
  • <!-- %PAR_INT_3% --> celé číslo
  • <!-- %PAR_NUM_1% --> reálné číslo
  • <!-- %PAR_NUM_2% --> reálné číslo
  • <!-- %PAR_NUM_3% --> reálné číslo
  • <!-- %PAR_DAT_1% --> datum
  • <!-- %PAR_DAT_2% --> datum
  • <!-- %PAR_DAT_3% --> datum
  • <!-- %PAR_LOG_1% --> logická hodnota
  • <!-- %PAR_LOG_2% --> logická hodnota
  • <!-- %PAR_LOG_3% --> logická hodnota
  • <!-- %IS_PAR_LOG_1()% --> zapíše se parametr pokud je PAR_LOG1 zatržený
  • <!-- %IS_PAR_LOG_2()% --> zapíše se parametr pokud je PAR_LOG2 zatržený
  • <!-- %IS_PAR_LOG_3()% --> zapíše se parametr pokud je PAR_LOG3 zatržený
  • <!-- %01% --> střídavě zapisuje hodnotu 1 a 0 (střídající se vzhled po řádku)
  • <!-- %LEFT_RIGHT% --> střídavě zapisuje hodnotu LEFT a RIGHT (střídavé zarovnání obrázku)
  • <!-- %RIGHT_LEFT% --> střídavě zapisuje hodnotu RIGHT a LEFT (střídavé zarovnání obrázku)

Stánky s detailem karet (pro nastavení "samostatný detail")

  • <!-- %DETAIL_LAST_PAGE% --> předchozí detail
  • <!-- %DETAIL_NEXT_PAGE% --> následující detail
  • <!-- %IS_DETAIL_LAST_PAGE()% --> zapíše parametr pokud existuje předchozí detail zboží ve stejné kategorii
  • <!-- %IS_DETAIL_NEXT_PAGE()% --> zapíše parametr pokud existuje následující detail zboží ve stejné kategorii
  • <!-- %GROUP_NAME% --> název oddělení, kde je karta zatříděna
  • <!-- %GROUP_LINK% --> odkaz na oddělení, kde je karta zatříděna
  • <!-- %RELATED_FILE% --> odkaz na související karty I.(pokud není tak ="_nul.js")
  • <!-- %RELATED_FILE2% --> odkaz na související karty II.(pokud není tak ="_nul.js")
  • <!-- %RELATED_FILE3% --> odkaz na související karty III.(pokud není tak ="_nul.js")

Údaje o detailu karty (pro nastavení "samostatný detail")

<!-- %VIEW_GOODS_START% --> <!-- %VIEW_GOODS_END% --> začátek/konec údajů o kartě
  • <!-- %PRICE1_REAL% --> cena 1 s DPH jako číslo
  • <!-- %PRICE1_WITHOUT_REAL% --> cena 1 bez DPH jako číslo
  • <!-- %PRICE1_STRING% --> cena 1 s DPH zobrazená jako textový údaj (12,-)
  • <!-- %PRICE1_WITHOUT_STRING% --> cena 1 bez DPH zobrazená jako textový údaj (12,-)
  • <!-- %PRICE2_WITHOUT_REAL% --> cena 2 bez DPH zapsaná jako číslo
  • <!-- %PRICE3_WITHOUT_REAL% --> cena 3 bez DPH zapsaná jako číslo. Využití pro stanovení ceny na základě objednaného množství.
  • <!-- %SPECS% --> provedení (A/N)
  • <!-- %DET_NEW% --> novinka (A/N)
  • <!-- %MIN_QUANTITY% --> minimální množství
  • <!-- %DET_PRICE% --> deklarace cen1-3 bez a s DPH
  • <!-- %DET_OLD_PRICE% --> původní cena
  • <!-- %OLD_PRICE_STRING% --> původní cena zobrazená jako textový údaj (12,-)
  • <!-- %DET_DESCRIPTION% --> popis karty
  • <!-- %DET_DESCRIPTION_SEARCH% --> popis zboží bez HTML tágů. Pro soubor hledání, xml apod.
  • <!-- %DET_D_DESCRIPTION% --> detailní popis karty
  • <!-- %DET_IMAGE% --> detailni obrázek
  • <!-- %IS_NEW()% --> pokud se jedná o novinku zapíše se obsah parametru
  • <!-- %DISCOUNT()% --> pokud se jedná o slevu zapíše se obsah parametru
  • <!-- %IS_SALE()% --> pokud se jedná o výprodej zapíše se obsah parametru
  • <!-- %IS_SPECS()% --> pokud obsahuje provedení zapíše se obsah parametru
  • <!-- %IS_TIP()% --> pokud se jedná o tip zapíše se obsah parametru
  • <!-- %OLD_PRICE_STRING_IS% --> zapíše původní cenu, pokud je různá od 0 a současně je větší než cena 1 s DPH
  • <!-- %IS_OLD_PRICE()% --> zapíše parametr, pokud je původní cena různá od 0 a současně je větší než cena 1 s DPH
  • <!-- %IS_IMAGE()% --> zapíše parametr, pokud je náhledový obrázek zboží
  • <!-- %NOT_IMAGE()% --> zapíše parametr, pokud není náhledový obrázek zboží
  • <!-- %IMAGE_EXIST()% --> zapíše parametr, pokud není náhledový obrázek zboží, jinak zapíše malý obrázek
  • <!-- %DET_IMAGE_EXIST()% --> zapíše parametr, pokud není detailní obrázek zboží, jinak zapíše velký obrázek
  • <!-- %NOT_FIRST_PAGE()% --> zapíše parametr, pokud se nejedná o první stránku přehledu zboží
  • <!-- %NOT_BOTTOM_PAGE()% --> zapíše parametr, pokud se nejedná o poslední stránku přehledu zboží
  • <!-- %NO_TYPE_X()% --> zapíše parametr, pokud není zadána žádná varianta zboží na kartě (záložka 6-10)
  • <!-- %IS_TYPE_X()% --> zapíše parametr, pokud je zadána nějaká varianta zboží na kartě (záložka 6-10)
  • <!-- %IS_RELATED_FILE()% --> zapíše parametr, pokud je zadáno související zboží na kartě (záložka 2)
  • <!-- %IS_RELATED_FILE2()% --> zapíše parametr, pokud je zadáno související zboží na kartě (záložka 3)
  • <!-- %IS_RELATED_FILE3()% --> zapíše parametr, pokud je zadáno související zboží na kartě (záložka 4)
  • <!-- %BOOKMARK_2()% --> zapíše název záložky, pokud je něco na záložce 2 vyplněno
  • <!-- %BOOKMARK_3()% --> zapíše název záložky, pokud je něco na záložce 3 vyplněno
  • <!-- %BOOKMARK_4()% --> zapíše název záložky, pokud je něco na záložce 4 vyplněno
  • <!-- %BOOKMARK_6()% --> zapíše název záložky, pokud je něco na záložce 6 vyplněno
  • <!-- %BOOKMARK_7()% --> zapíše název záložky, pokud je něco na záložce 7 vyplněno
  • <!-- %BOOKMARK_8()% --> zapíše název záložky, pokud je něco na záložce 8 vyplněno
  • <!-- %BOOKMARK_9()% --> zapíše název záložky, pokud je něco na záložce 9 vyplněno
  • <!-- %BOOKMARK_10()% --> zapíše název záložky, pokud je něco na záložce 10 vyplněno
  • <!-- %BOOKMARK_11()% --> zapíše název záložky, pokud je něco na záložce 11 vyplněno
  • <!-- %BOOKMARK_12()% --> zapíše název záložky, pokud je něco na záložce 12 vyplněno
  • <!-- %BOOKMARK_13()% --> zapíše název záložky, pokud je něco na záložce 13 vyplněno
  • <!-- %NAME_PAR_STR_0% --> název sloupce NAME_PAR_STR_0
  • <!-- %NAME_PAR_STR_1% --> název sloupce NAME_PAR_STR_1
  • <!-- %NAME_PAR_STR_2% --> název sloupce NAME_PAR_STR_2
  • <!-- %NAME_PAR_STR_3% --> název sloupce NAME_PAR_STR_3
  • <!-- %NAME_PAR_STR_4% --> název sloupce NAME_PAR_STR_4
  • <!-- %NAME_PAR_STR_5% --> název sloupce NAME_PAR_STR_5
  • <!-- %NAME_PAR_NUM_1% --> název sloupce NAME_PAR_NUM_1
  • <!-- %NAME_PAR_NUM_2% --> název sloupce NAME_PAR_NUM_2
  • <!-- %NAME_PAR_NUM_3% --> název sloupce NAME_PAR_NUM_3
  • <!-- %NAME_PAR_INT_1% --> název sloupce NAME_PAR_INT_1
  • <!-- %NAME_PAR_INT_2% --> název sloupce NAME_PAR_INT_2
  • <!-- %NAME_PAR_INT_3% --> název sloupce NAME_PAR_INT_3
  • <!-- %NAME_PAR_DAT_1% --> název sloupce NAME_PAR_DAT_1
  • <!-- %NAME_PAR_DAT_2% --> název sloupce NAME_PAR_DAT_2
  • <!-- %NAME_PAR_DAT_3% --> název sloupce NAME_PAR_DAT_3
  • <!-- %NAME_PAR_LOG_1% --> název sloupce NAME_PAR_LOG_1
  • <!-- %NAME_PAR_LOG_2% --> název sloupce NAME_PAR_LOG_2
  • <!-- %NAME_PAR_LOG_3% --> název sloupce NAME_PAR_LOG_3
  • <!-- %ITEM_ON_PAGE% --> počet položek na stránce s přehledem zboží
  • <!-- %TYPE_1% --> provedení záložky 6 (rozbalovací nabídka)
  • <!-- %TYPE_2% --> provedení záložky 7 (rozbalovací nabídka)
  • <!-- %TYPE_3% --> provedení záložky 8 (rozbalovací nabídka)
  • <!-- %TYPE_4% --> provedení záložky 9 (rozbalovací nabídka)
  • <!-- %TYPE_5% --> provedení záložky 10 (rozbalovací nabídka)
  • <!-- %TYPE_1R()% --> provedení záložky 6 (rádio tlačítka), parametr je oddelovač mezi hodnotami
  • <!-- %TYPE_2R()% --> provedení záložky 7 (rádio tlačítka), parametr je oddelovač mezi hodnotami
  • <!-- %TYPE_3R()% --> provedení záložky 8 (rádio tlačítka), parametr je oddelovač mezi hodnotami
  • <!-- %TYPE_4R()% --> provedení záložky 9 (rádio tlačítka), parametr je oddelovač mezi hodnotami
  • <!-- %TYPE_5R()% --> provedení záložky 10 (rádio tlačítka), parametr je oddelovač mezi hodnotami
  • <!-- %TYPE_IMG% --> další obrázky s popisem, záložka 11
  • <!-- %TYPE_IMG_III% --> další obrázky s popisem, záložka 11, které se otevírají pomocí Lightbox2, ukázka
  • <!-- %TYPE_IMG_IV()% --> zobrazí parametr, pokud existují další obrázky (záložka 11), které se otevírají pomocí Lightbox2, ukázka
  • <!-- %TYPE_IMG_V()% --> zobrazí parametr, pokud neexistují další obrázky (záložka 11), vygeneruje odkaz na detailní obrázek, který se otevře pomocí Lightbox2, ukázka
  • <!-- %TABLE_1% --> jednosloupcová tabulka, záložka 12
  • <!-- %TABLE_2% --> dvousloupcová tabulka, záložka 13
  • <!-- %TABLE_2_HREF()% --> záložka 13 (tabulka varianta 2), pravé tl. myši nalistování souboru 1. sloupec odkaz, 2. sloupec text odkazu
  • <!-- %TABLE_2_HREF_W()% --> záložka 13 (tabulka varianta 2), pravé tl. myši nalistování souboru 1. sloupec odkaz, 2. sloupec text odkazu. Odkazy se otevírají do nového okna
  • <!-- %IS_TYPE_1()% --> zapíše parametr, pokud je vyplněna záložka 6
  • <!-- %IS_TYPE_2()% --> zapíše parametr, pokud je vyplněna záložka 7
  • <!-- %IS_TYPE_3()% --> zapíše parametr, pokud je vyplněna záložka 8
  • <!-- %IS_TYPE_4()% --> zapíše parametr, pokud je vyplněna záložka 9
  • <!-- %IS_TYPE_5()% --> zapíše parametr, pokud je vyplněna záložka 10
  • <!-- %IS_TYPE_IMG()% --> zapíše parametr, pokud je vyplněna záložka 11
  • <!-- %IS_TABLE_1()% --> zapíše parametr, pokud je vyplněna záložka 12
  • <!-- %IS_TABLE_2()% --> zapíše parametr, pokud je vyplněna záložka 13
  • <!-- %PAR_STR_0% --> text 255 znaků
  • <!-- %PAR_STR_1% --> text 50 znaků
  • <!-- %PAR_STR_2% --> text 50 znaků
  • <!-- %PAR_STR_2% --> text 50 znaků
  • <!-- %PAR_STR_4% --> text 50 znaků
  • <!-- %PAR_STR_5% --> text 50 znaků. Může obsahovat klíčové slovo <!-- %TEXT_1% --> <!-- %TEXT_2% --> <!-- %TEXT_3% --> <!-- %TEXT_4% --> . Buď obsahuje libovolný text nebo pouze klíčové slovo
  • <!-- %PAR_INT_1% --> celé číslo
  • <!-- %PAR_INT_2% --> celé číslo
  • <!-- %PAR_INT_3% --> celé číslo
  • <!-- %PAR_NUM_1% --> reálné číslo
  • <!-- %PAR_NUM_2% --> reálné číslo
  • <!-- %PAR_NUM_3% --> reálné číslo
  • <!-- %PAR_DAT_1% --> datum
  • <!-- %PAR_DAT_2% --> datum
  • <!-- %PAR_DAT_3% --> datum
  • <!-- %PAR_LOG_1% --> logická hodnota
  • <!-- %PAR_LOG_2% --> logická hodnota
  • <!-- %PAR_LOG_3% --> logická hodnota

Speciální skupiny karet

  • <!-- %VIEW_GOODS_START_NEWS% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku novinky
  • <!-- %VIEW_GOODS_START_TIP% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku tip
  • <!-- %VIEW_GOODS_START_TOP% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku toplist
  • <!-- %VIEW_GOODS_START_SALE% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku výprodej
  • <!-- %VIEW_GOODS_START_DISCOUNT% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku sleva
  • <!-- %VIEW_GOODS_START_RELATED_FILE% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku související karty I
  • <!-- %VIEW_GOODS_START_RELATED_FILE2% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku související karty II
  • <!-- %VIEW_GOODS_START_RELATED_FILE3% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku související karty III
  • <!-- %VIEW_GOODS_START_RELATED_FILE()% --> začátek skupiny související položky s možnosti definování třídění v parametru. Např.
    <!-- %VIEW_GOODS_START_RELATED_FILE(ORDER BY kod DESC)% --> dle položky sestupně
    ORDER BY NAZEV dle názvu
    ORDER BY CENABDPH dle ceny bez DPH
  • <!-- %VIEW_GOODS_START_RELATED_FILE2()% --> začátek skupiny související položky 2 s možnosti definování třídění v parametru.
  • <!-- %VIEW_GOODS_START_RELATED_FILE3()% --> začátek skupiny související položky 3 s možnosti definování třídění v parametru.
  • <!-- %VIEW_GOODS_START_01% --> začátek položek 1. sloupec ze 3
  • <!-- %VIEW_GOODS_START_02% --> začátek položek 2. sloupec ze 3
  • <!-- %VIEW_GOODS_START_03% --> začátek položek 3. sloupec ze 3
  • <!-- %COUNT_RELATED_FILE1% --> počet souvisejících položek 1
  • <!-- %COUNT_RELATED_FILE2% --> počet souvisejících položek 2
  • <!-- %COUNT_RELATED_FILE3% --> počet souvisejících položek 3
  • <!-- %VIEW_GOODS_START_GROUP% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku skupiny karet náležijící do aktuální meziskupiny. Slouží pro vyobrazení zboží u skupiny, která se dále dělí. Karty, které se mají tady zobrazit, se musí ručně začlenit do této skupiny. Využije se druhé nebo další začlenění do skupiny.
  • <!-- %VIEW_GOODS_START_GROUPS% --> <!-- %VIEW_GOODS_END% --> začátek/konec bloku pro karty spadající do aktuální nadřízené skupiny
  • <!-- %VIEW_GOODS_START_GROUPS_TIP()% --> začátek bloku zboží označené jako TIP. Parametr určuje maximální počet zobrazených položek
  • <!-- %VIEW_GOODS_START_GROUPS_1% --> začátek bloku zboží náležící do aktuální nadřízené skupiny - liché položky
  • <!-- %VIEW_GOODS_START_GROUPS_0% --> začátek bloku zboží náležící do aktuální nadřízené skupiny - sudé položky
  • pro zobrazení dalších údajů se dají použít klíčová slova shodná pro zobrazení detailu karty.

režim expert


Názvy sloupců

nazvysloupcu.gif, 7 kB
Nastavení názvů doplňujících údajů karet (záložka číslo 5) v režimu expert.
Pokud se doplní znak X údaj se nezobrazí.

Pro zobrazení obsahu sloupce na www stránce jsou klíčová slova
  • <!-- %PAR_STR_0% --> text 255 znaků
  • <!-- %PAR_STR_1% --> text 50 znaků
  • <!-- %PAR_STR_2% --> text 50 znaků
  • <!-- %PAR_STR_2% --> text 50 znaků
  • <!-- %PAR_STR_4% --> text 50 znaků
  • <!-- %PAR_STR_5% --> text 50 znaků. Může obsahovat klíčové slovo <!-- %TEXT_1% --> <!-- %TEXT_2% --> <!-- %TEXT_3% --> <!-- %TEXT_4% --> . Buď obsahuje libovolný text nebo pouze klíčové slovo
  • <!-- %PAR_INT_1% --> celé číslo
  • <!-- %PAR_INT_2% --> celé číslo
  • <!-- %PAR_INT_3% --> celé číslo
  • <!-- %PAR_NUM_1% --> reálné číslo
  • <!-- %PAR_NUM_2% --> reálné číslo
  • <!-- %PAR_NUM_3% --> reálné číslo
  • <!-- %PAR_DAT_1% --> datum
  • <!-- %PAR_DAT_2% --> datum
  • <!-- %PAR_DAT_3% --> datum
  • <!-- %PAR_LOG_1% --> logická hodnota
  • <!-- %PAR_LOG_2% --> logická hodnota
  • <!-- %PAR_LOG_3% --> logická hodnota

Karty Názvy záložek


Názvy záložek

nazvy_zalozek.gif, 6 kB
Nastavení názvu záložek karet v režimu expert.
Pro zobrazení názvu záložky/vlastnosti karty na www stránce slouží klíčová slova
<!-- %BOOKMARK_2% --> až <!-- %BOOKMARK_4% --> a <!-- %BOOKMARK_6% --> až <!-- %BOOKMARK_13% -->
Text se vypíše pouze u karty, která má vyplněný nějaký text u konkrétní záložky/vlastnosti.

Pro podmíněný výpis textu-kódu HTML slouží klíčová slova
  • <!-- %IS_RELATED_FILE()% --> pokud je vyplněna záložka 2 je zobrazen text/HTML kód obsažený mezi závorkami klíčového slova. Např. slovo AHOJ se zobrazí pokud je u karty vyplněna záložka č. 2 a je použito kl. slovo ve tvaru <!-- %IS_RELATED_FILE(AHOJ)% -->
  • <!-- %IS_RELATED_FILE2()% --> pro záložku 3
  • <!-- %IS_RELATED_FILE3()% --> pro záložku 4
  • <!-- %IS_TYPE_1()% --> pro záložku 6
  • <!-- %IS_TYPE_2()% --> pro záložku 7
  • <!-- %IS_TYPE_3()% --> pro záložku 8
  • <!-- %IS_TYPE_4()% --> pro záložku 9
  • <!-- %IS_TYPE_5()% --> pro záložku 10
  • <!-- %IS_TYPE_IMG()% --> pro záložku 11
  • <!-- %IS_TABLE_1()% --> pro záložku 12
  • <!-- %IS_TABLE_2()% --> pro záložku 13

Karty Názvy sloupců


NetBanka

Nastavení parametrů platební brány.

netbanka.png, 6 kB

Údaje se vyplní podle údajů obchodníka. Podmínkou není zřízení účtu v ŽIVNOSTENSKÉ BANCE
Způsob úhrady eBanka


Obecná tlačítka na ovládací liště

Pracovní lišta při otevřeném pohledu má tyto podoby:

Základní sestava tlačítek je následující:

V režimu kladení dotazu se tlačítka změní na

Zobrazení výsledku dotazu

Je-li otevřen vázací pohled, na liště přibude ještě jedno tlačítko:

Význam tlačítek zleva doprava je:
vystřihnout text do clipboardu;
zkopírovat text do clipboardu;

vlepit text z clipboardu;
skok na první záznam pohledu;
skok o stránku dozadu;
skok o jeden záznam dozadu;
skok o jeden záznam dopředu;
skok o stránku dopředu;
skok na poslední záznam pohledu;
položení dotazu v jazyce QBE;
zadání uspořádání záznamů;
konec zadávání dotazu nebo uspořádání nebo zrušení dotazu a uspořádání;
zrušení běžného záznamu v pohledu;
zrušení všech záznamů v pohledu;
tisk obsahu pohledu;
otevření okna se složkami multiatributu;
otevření okna pro zamykání a aktualizaci pohledu;
otevření okna pro export záznamů z pohledu vč. odeslání elektronickou poštou.

Uživatelské pohledy mají často svá vlastní tlačítka, která jsou popsána pro konkrétní pohled.

Práce s pohledem


Načtení obrázků do databáze

Funkce pro hromadné pořízení nových karet, s dosazením dalších parametrů. Vhodná např. pro doplňování nových fotek pro rozsáhlejší fotogalerii.

obrdodatabaze.gif, 6 kB

Popis údajů

  • Adresář s náhledovými obrázky - složka, ve které jsou nové obrázky
  • Kód jako název soubor - do kódu karty se dosadí jméno souboru s obrázkem bez přípony
  • Text před číslem - před číslem použitým v kódu karty se uvede text(jinak za číslem)
  • Číslovat od - první číslo použité v kódu karty
  • Kategorie - kód kategorie, kde patří nové karty
  • Jména souborů na malé písmena - názvy souborů se načtou/nenačtou s automatickou změnou na malé písmena. Má vliv hlavně při umístění na internetu, kde se rozlišují velká a malá písmena


PayPal

Nastavení parametrů platební brány.

paypal.gif, 8 kB

  • e-mail - e-mailová adresa účtu na PayPal
  • název transakce - text, který se objeví u transakce na PayPalu
  • návratová adresa po úspěšné platbě - URL adresa včetně http://
  • návratová adresa po neúspěšné platbě - URL adresa včetně http://
  • měna - kód měny CZK, USD, ...
Podmínkou je zřízení účtu v Paypal
Způsob úhrady eBanka


Podskupiny

Pořizování, editace, mazání podskupin produktu.

Popis údajů

  • Skupina - jméno skupiny, do které podskupina patří. Nalistování skupiny - ALT+šipka dolů
  • Kód PSK - kódové označení podskupiny
  • Název podskupiny - název podskupiny. Text, který se zobrazí jako odkaz na podskupinu (pokud není vyplněn obrázek).
  • Obrázek - soubor s obrázkem. Nalistování obrázku - pravé tl. myši. Obrázek pokud je vyplněn se zobrazí namísto textového odkazu.
  • Alternativní popis - popis obrázku. Při najetí myší na obrázek se zobrazí tento text.
Pozn. Použití podskupin není nutné. Postačí rozdělení na skupiny.
Karty Skupiny Zatřídění


 Pokud se Vám neotevřela nápověda pro určité okno přejděte na záložku Obsah a pod složkou Hlavní nabídka si nalistujte správnou nápovědu.

Práce s pohledem na obrazovce

Pro práci s pohledem na obrazovce jsou podstatné tyto informace:
složky pohledu ;
ovládací tlačítka;

Většinu akcí souvisejících s pohledem lze vyvolat buď stiskem klávesy, nebo myší, anebo ze systémového menu pohledu.

Okno pohledu má tyto hlavní částí:

Rám okna, který dovoluje měnit rozměry a polohu okna způsobem běžným v Windows. Na rámu jsou v pravém horním rohu tlačítka pro roztažení a ikonizaci pohledu, v levém horním rohu tlačítko systémového menu. Systémové menu můžete otevřít stiskem tohoto tlačítka myší nebo kombinací kláves Alt mezera a pak šipka doprava.

Táhlo u pravého rámu okna, které dovoluje se pohybovat mezi záznamy v pohledu nahoru a dolů. Pokud stisknete tlačítko myši pod nebo nad táhlem, posunete se o jednu stránku dopředu nebo dozadu. Pokud stisknete tlačítko myši na šipce pod nebo nad táhlem, posunete se o jeden záznam dopředu nebo dozadu. Táhlo není v těch pohledech, které vedou do proměnných projektu. POZOR: V některých pohledech poloha táhla nevyjadřuje poměr počtu záznamů před a za běžnou pozicí, protože WinBase dosud neví, kolik záznamů bude pohled obsahovat.

Řada ovládacích tlačítek, z nichž některá mohou být neviditelná. Tato tlačítka se objevují pouze tehdy, pokud to požaduje návrh pohledu, proto v některých pohledech nebudou.

Hlava okna, specifikovanou v návrhu pohledu.

Jeden nebo více záznamů, podle návrhu pohledu. V záznamech (případně i v hlavě okna) vidíte složky pohledu. Stiskem myši na tlačítkách, označovacích čtvercích a na některých hodnotových složkách vyvoláte akci zadanou návrhem pohledu.

POZOR: Při editaci údaje ve složce pohledu se Vámi pozměněný údaj zapíše do databáze v okamžiku, když po editaci stisknete klávesu Enter nebo když se pokusíte přejít na jinou složku pohledu. Pokud se Vámi zadaná hodnota nedá zapsat, pak je ohlášena chyba a složku nemůžete opustit. Musíte buď opravit hodnotu nebo upustit od zápisu tak, že stisknete klávesu ESC resp Shift+ESC.


Rubriky

rubriky_red.png, 7 kB

Popis údajů

  • Jméno rubriky - jméno rubriky
  • Soubor HTML - jméno souboru, ve kterém bude rubrika uložena. Jméno se stanovuje podle pravidel.
  • Alternativní popis - popis v bublině, při najetí kurzoru nad textový odkaz
  • Pořadí - pozice zobrazení rubriky na stránce
  • Nadřízená rubrika - jméno rubriky, která je nadřízenou pro tuto rubriku. Uvádí se pouze v případě, že jsou použity nadřízené rubriky
  • SUBCATEGORY_TEXT_1 - HTML text, který se zobrazí na stránce v místě, kde je umístěné v šabloně klíčové slovo <!-- %SUBCATEGORY_TEXT_1% -->

Popis tlačítek

  • Upravit - editace textu v interním editoru
  • EE - editace textu v externím editoru
  • OK - uložení změn a zavření okna
  • Odvolat změny - odvolání změn a zavření okna
  • Vložit záznam - vložení nové rubriky
  • Zrušit záznam - smaže rubriku
  • HTML - otevře nápovědu s tématem HTML kód

Nadřízené rubriky

Používá se pouze v tom případě, že je potřeba dvouúrovňové členění rubrik

    Nábytek
        - Postele
        - Židle
        - Sedačky
    Doplňky
        - Obrázky
        - dekorace

rubriky_nad.png, 6 kB

Popis údajů

  • Jméno rubriky - jméno rubriky
  • Soubor HTML - jméno souboru, ve kterém bude rubrika uložena. Jméno se stanovuje podle pravidel.
  • Alternativní popis - popis v bublině, při najetí kurzoru nad textový odkaz
  • Pořadí - pozice zobrazení rubriky na stránce
  • CATEGORY_TEXT_1 - HTML text, který se zobrazí na stránce v místě, kde je umístěné klíčové slovo <!-- %CATEGORY_TEXT_1% -->

Popis tlačítek

  • Upravit - editace textu v interním editoru
  • EE - editace textu v externím editoru
  • OK - uložení změn a zavření okna
  • Odvolat změny - odvolání změn a zavření okna
  • Vložit záznam - vložení nové rubriky
  • Zrušit záznam - smaže rubriku
  • HTML - otevře nápovědu s tématem HTML kód

Klíčová slova Weblog


Složky pohledu

Pohled obsahuje jeden nebo více záznamů (jsou pod sebou), každý záznam se skládá z jistého počtu složek (jsou libovolně rozmístěny v záznamu). Složky jsou různých druhů. Pro vstup a editaci dat se dají použít tyto složky:

Editační složky jsou orámovány a pokud některou z nich vyberete, objeví se v ní svislý kurzor. Obsah složky můžete přepsat, přitom zadávání obsahu ukončíte stiskem klávesy Enter nebo přechodem na jinou složku. Pokud jste zadali nepřípustnou hodnotu, budete na to akusticky upozorněni a WinBase Vám nedovolí tuto složku opustit, dokud hodnotu neopravíte!! Vrátit se k původní hodnotě složky můžete stiskem klávesy ESC.

Označovací čtverec (angl. Check-box) je čtvereček s nápisem vpravo. Čtverec může být zaškrtnut nebo nezaškrtnut případně může mít nedefinovanou hodnotu. Čtverec zaškrtnete nebo zaškrtnutí odstraníte tak, že na něm stisknete tlačítko myši nebo mezerník, je-li čtverec předem vybrán. Standardní použití je pro zápis do atributu typu Boolean. Vybraný čtverec poznáte tak, že má kolem svého nápisu tečkovaný rámeček.

Přepínač (angl. Radio-button) - dvoustavové přepínače kruhového tvaru, vyplněné nebo nevyplněné. Přepínají se myší nebo pouhým nastavením se na ně pomocí klávesy TAB.

Seznam (angl. List-box) slouží k zpřístupnění hodnoty multiatributu. Listuje se v něm pomocí šipek. Je-li počet hodnot větší než velikost seznamu, objeví se v jeho pravé části svislé táhlo a grafické šipky pro ovládání myší.

Combo pole (angl. Combo-box) slouží k výběru z několika předem známých hodnot. V této složce se listuje pomocí šipek dolů a nahoru. Combo pole se rozevře pomocí kombinace ALT+šipka dolů nebo kliknutím myši.

Tlačítka se dají stisknout buď myší, nebo mezerníkem, pokud je tlačítko předtím vybráno. Stisk tlačítka způsobí určitou akci definovanou v návrhu. Vybrané tlačítko poznáte tak, že má kolem svého nápisu tečkovaný rámeček.

Práce s pohledem


Vlastní definice

Vlastní definice horního rámu.

Při použití vlastního formuláře je nutné zachovat název formuláře vysledky a název proměnné celkem.


Záložky

Přístupné pouze v režimu expert a licenci WebGen.cz Pro.

Záložka číslo 2,3,4

Ke kartě je možné přiřadit tři skupiny souvisejících položek (podobné, náhradní varianty, příslušenství ...). V detailu karty se lze pak na tyto karty odvolat.
Každá skupina má samostatnou šablonu. Název záložky jde měnit. Otevření okna pro editaci názvu záložky pomocí pravého tlačítka myši na názvu záložky.

Popis tlačítek

  • tl_e_editor.gif, 0 kB - externí editor pro editaci popisu
  • tl_e_editor.gif, 0 kB - externí editor pro editaci detailního popisu
  • tl_ukaz.gif, 0 kB - náhled obrázku
  • tl_obnov.gif, 0 kB - aktualizace údajů po smazání související položky
  • HTML ? - otevření okna se základními HTML tágy

Záložka číslo 5

zbozi_det5.gif, 3 kB

Doplňující údaje s možností nastavení vlastních názvů zobrazovaných údajů. Klíčová slova pro zobrazení obsahu jsou uvedena zde.

Záložka číslo 6

zalozka6.gif, 4 kB

Zobrazení obsahu nabídky na stránkách klíčovým slovem <!-- %TYPE_1% -->.
Zobrazí se :

Vygenerovaný kód:
<select name="ADDITIONALINFO">
<option value="modrá">modrá</option>
<option value="zelená">zelená</option>
<option value="hnědá">hnědá</option>
<option value="bílá">bílá</option>
</select>
 Pro zobrazení nabídky včetně názvu se použije <!-- %BOOKMARK_6% --> <!-- %TYPE_1% -->.
Zobrazí se :
Provedení 1 - barva

Záložka číslo 7

zalozka7.gif, 4 kB

Zobrazení obsahu nabídky na stránkách klíčovým slovem <!-- %TYPE_2% -->.
Zobrazí se :

Vygenerovaný kód:
<select name="ADDITIONALINFO2">
<option value="110">110</option>
<option value="115">115</option>
<option value="120">120</option>
</select>

Záložka číslo 8

zalozka8.gif, 4 kB

Zobrazení obsahu nabídky na stránkách klíčovým slovem <!-- %TYPE_3% -->.
Zobrazí se :

Vygenerovaný kód:
<select name="ADDITIONALINFO3">
<option value="buk">buk</option>
<option value="dub">dub</option>
</select>

Záložka číslo 9

zalozka9.gif, 4 kB

Zobrazení obsahu nabídky na stránkách klíčovým slovem <!-- %TYPE_4% -->.
Zobrazí se :

Vygenerovaný kód:
<select name="ADDITIONALINFO4">
<option value="15">15</option>
<option value="20">20</option>
<option value="25">25</option>
<option value="30">30</option>
</select>

Záložka číslo 10

zalozka10.gif, 5 kB

Sloupec Cena obsahuje cenu bez DPH pro konkrétní variantu. Pokud není cena uvedena bere se základní prodejní cena. Zobrazení obsahu nabídky na stránkách klíčovým slovem <!-- %TYPE_5% -->.
Zobrazí se :

Vygenerovaný kód:
<select name="ADDITIONALINFOx">
<option value="30cm">30cm</option>
<option value="100^35cm">35cm</option>
<option value="120^40cm">40cm</option>
<option value="15^50cm">50cm</option>
</select>

Záložka číslo 11

zalozka11.gif, 4 kB

Malý obrázek spolu s textem se zobrazí na stránce. Velký obrázek se zobrazí po kliknutí na malý obrázek v novém okně ve skutečné velikosti. Zobrazení na stránkách klíčovým slovem <!-- %TYPE_IMG% -->.

Vygenerovaný kód, ukázka pro jeden řádek(fotku): <div class="type_img"> <div class="img_obr"> <a href="det_obr.htm?pod=detail/asusl.jpg" target="_blank" class="img_a"> <img src="obr/asusl.jpg"> </a> </div> <div class="img_text"> <a href="det_obr.htm?pod=detail/asusl.jpg" target="_blank" class="img_a"> zleva </a> </div> </div> Zobrazí se např.:
vzalozka11.png, 20 kB
Vzhled je plně v rukou nastavení CSS

Záložka číslo 12

zalozka12.gif, 4 kB

Jednosloupcová tabulka.
Zobrazení na stránkách klíčovým slovem <!-- %TABLE_1% -->.

Vygenerovaný kód :
<div class="table1">
  <div class="r0_table1">SMS </div>
  <div class="r1_table1">MMS</div>
  <div class="r0_table1">EDGE</div>
</div>
 Zobrazí se např.:
vzalozka12.gif, 0 kB
Vzhled je plně v rukou nastavení CSS

Záložka číslo 13

zalozka13.gif, 4 kB

Dvousloupcová tabulka.
Zobrazení na stránkách klíčovým slovem <!-- %TABLE_2% -->.

Vygenerovaný kód : <div class="table2"> <div class="r0_table2"> <div class="s10_table2"> <span class="s1">Typ telefonu</span> </div> <div class="s20_table2">Neblokovaný </div> <div class="clear"> </div> </div> <div class="r1_table2"> <div class="s11_table2"> <span class="s1">Typ displeje</span> </div> <div class="s21_table2">Barevný (208 × 320 bodů, 262 tisíc barev) </div> <div class="clear"> </div> </div> </div> Zobrazí se např.:
vzalozka13.png, 2 kB
Vzhled je plně v rukou nastavení CSS

Karty Názvy sloupců Názvy záložek